summaryrefslogtreecommitdiff
path: root/dev-python/ijson/ijson-2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /dev-python/ijson/ijson-2.4.ebuild
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'dev-python/ijson/ijson-2.4.ebuild')
-rw-r--r--dev-python/ijson/ijson-2.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/ijson/ijson-2.4.ebuild b/dev-python/ijson/ijson-2.4.ebuild
new file mode 100644
index 000000000000..eceba6c8c743
--- /dev/null
+++ b/dev-python/ijson/ijson-2.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="https://github.com/isagalaev/ijson https://pypi.org/project/ijson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/yajl"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# pypi release lacks tests and git release isn't tagged yet
+# python_test() {
+# ${EPYTHON} tests.py || die
+# }