summaryrefslogtreecommitdiff
path: root/dev-python/ifaddr/ifaddr-0.1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/ifaddr/ifaddr-0.1.7.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/ifaddr/ifaddr-0.1.7.ebuild')
-rw-r--r--dev-python/ifaddr/ifaddr-0.1.7.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/ifaddr/ifaddr-0.1.7.ebuild b/dev-python/ifaddr/ifaddr-0.1.7.ebuild
new file mode 100644
index 000000000000..c125ab421907
--- /dev/null
+++ b/dev-python/ifaddr/ifaddr-0.1.7.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Enumerate IP addresses on the local network adapters"
+HOMEPAGE="https://github.com/pydron/ifaddr"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest