summaryrefslogtreecommitdiff
path: root/dev-python/idna
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/idna
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/idna')
-rw-r--r--dev-python/idna/Manifest7
-rw-r--r--dev-python/idna/idna-2.5.ebuild23
-rw-r--r--dev-python/idna/idna-2.6.ebuild23
-rw-r--r--dev-python/idna/idna-2.7.ebuild23
-rw-r--r--dev-python/idna/metadata.xml12
5 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/idna/Manifest b/dev-python/idna/Manifest
new file mode 100644
index 000000000000..b6d2872ae196
--- /dev/null
+++ b/dev-python/idna/Manifest
@@ -0,0 +1,7 @@
+DIST idna-2.5.tar.gz 130211 BLAKE2B 3b00b76f9d86f0961ca4613c4239e39fa19c28f60640d2c9d9b7ea05985f9eceac122bb9e5b30b2f22648506580202a187f95513fe5ab0af6632917335f2eda0 SHA512 29a69ede25a8855135c763da5d20ff81832c710038a38521c127d5b7b24b355c6cfa5e9f9a2a4ef1fa4437537d1d9e4b448357e07b4b5e3724d98fee0a3b7835
+DIST idna-2.6.tar.gz 135992 BLAKE2B 1397c93eae23a9ecbcc001205e83fd684cbdb4f0c916c30b7d80dc7fdd43c588a9a81a620a39108a31707c1aee8c4a315d1988ae5a8cf1f6519bb11bad6dc3a3 SHA512 cb5dbfab44c4d11521c67f9d29391f184d1267a3da6dc89f4ed12c60a7a909d5c7474c3ea2bddd0af7063f4f620e87a8dd586bb07e8b961b30b1dd7c969704c2
+DIST idna-2.7.tar.gz 172698 BLAKE2B d0c92988d78629af3b87b8b4842757395c1f439f25d77614ba05d48e57d7d9a414c5be33e3fcf191f7dc8fea7325c801ff9c6f687204dec3735406f6e2342923 SHA512 34ba985862e386243f43616586e53830177cf4ba0925b6054198dfa63c085ec5c6c5b54c2b3c0989bc768aacceeef76b84471e58a16183b960dc4b8812cd1c61
+EBUILD idna-2.5.ebuild 603 BLAKE2B 383fd5b4146d19a72a999cab1726c412a072a728ca8151a94a2166705fb3c040c2e5df7afcd3788fc2caef209ac127b61b4ee901959236cd2d69a95faca1fd2a SHA512 a68e990ed5fed97171450408d19bdb0cccc90a58658eff9da40e3e0099716d44d238a22ef4e7ba832a2eb6fa69a7cb65408b09435935c1385cfe854bef95470e
+EBUILD idna-2.6.ebuild 668 BLAKE2B c12ff33bfa42471d9aaf9ebb063b51e47ec5c0d8cd9bcaf18230dd853a52d4f00ea4a2f27b985a84893d86863eb61ee239c32087b5d4de1688d2d7c7dd554c93 SHA512 bc90f9e990b558075d9c77663781d44b9ecd2571747be0b041b0f1b2bb171e8a32d247e8149a83a586f8297f0bbeb9c3f67c13bd6669d615f959a576211a765f
+EBUILD idna-2.7.ebuild 679 BLAKE2B 4600ecb28a73e4897d1ddf1349d6a1f93a8444a64be2ad1502a19ab2207e691ce50e8cc421d71a380fa1baa8a45f4979b3b11fb4957e1c79ab62d299e3a32343 SHA512 f7b8ddc3e2cf0420af099cbf647ae7eedb99254d8344a31c360249cbbc0fb651eb4b97cbb06013f33ce03d65ed9b2cd393cb11a46c515d8f7ba9c19bfacef14f
+MISC metadata.xml 367 BLAKE2B 363038f61cdb96780faecfb8c92d97d0cea8146d37374a731daa9618150b3f41c0bad724619d7bb353141834df9fcb88f075ece91a742ccca2da1621e5b8e2fc SHA512 50f13044fec18651463e6199826a39c7f28c783e7da389017e2dc2fd6f17b6c93e4e437a1019e0e31605a06a428c31a2fbc12744daa957cefbba2d76b511331e
diff --git a/dev-python/idna/idna-2.5.ebuild b/dev-python/idna/idna-2.5.ebuild
new file mode 100644
index 000000000000..b6210152bf71
--- /dev/null
+++ b/dev-python/idna/idna-2.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Internationalized Domain Names in Applications (IDNA)"
+HOMEPAGE="https://github.com/kjd/idna"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/idna/idna-2.6.ebuild b/dev-python/idna/idna-2.6.ebuild
new file mode 100644
index 000000000000..f57d72cfe473
--- /dev/null
+++ b/dev-python/idna/idna-2.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Internationalized Domain Names in Applications (IDNA)"
+HOMEPAGE="https://github.com/kjd/idna https://pypi.org/project/idna/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/idna/idna-2.7.ebuild b/dev-python/idna/idna-2.7.ebuild
new file mode 100644
index 000000000000..e02a3406f4b9
--- /dev/null
+++ b/dev-python/idna/idna-2.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Internationalized Domain Names in Applications (IDNA)"
+HOMEPAGE="https://github.com/kjd/idna https://pypi.org/project/idna/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/idna/metadata.xml b/dev-python/idna/metadata.xml
new file mode 100644
index 000000000000..6ce490eacf0b
--- /dev/null
+++ b/dev-python/idna/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">idna</remote-id>
+ <remote-id type="github">kjd/idna</remote-id>
+ </upstream>
+</pkgmetadata>