summaryrefslogtreecommitdiff
path: root/dev-python/idna/idna-3.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-12 06:33:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-12 06:33:48 +0100
commited7b29dac0f97dbcf5472b7556b83731a6b6b0d4 (patch)
treef33c5735088b95071719669ecfc18f0aef491ee9 /dev-python/idna/idna-3.7.ebuild
parent3a6d209caa07e3be8e8423251b70c8bbeeedb17f (diff)
gentoo auto-resync : 12:04:2024 - 06:33:48
Diffstat (limited to 'dev-python/idna/idna-3.7.ebuild')
-rw-r--r--dev-python/idna/idna-3.7.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/idna/idna-3.7.ebuild b/dev-python/idna/idna-3.7.ebuild
new file mode 100644
index 000000000000..f8acef3ce04a
--- /dev/null
+++ b/dev-python/idna/idna-3.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Internationalized Domain Names in Applications (IDNA)"
+HOMEPAGE="
+ https://github.com/kjd/idna/
+ https://pypi.org/project/idna/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests unittest