summaryrefslogtreecommitdiff
path: root/dev-python/identify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/identify
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/identify')
-rw-r--r--dev-python/identify/Manifest5
-rw-r--r--dev-python/identify/identify-2.2.3.ebuild21
-rw-r--r--dev-python/identify/identify-2.2.4.ebuild21
-rw-r--r--dev-python/identify/metadata.xml12
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
new file mode 100644
index 000000000000..b27c9787f502
--- /dev/null
+++ b/dev-python/identify/Manifest
@@ -0,0 +1,5 @@
+DIST identify-2.2.3.tar.gz 100962 BLAKE2B 0e56b7443f19e0956b72c428b2cf4c741b10cb38e6cad3efa6fa130d3ac1ec84e351d049c58bac9098b85cd32d64459f96e2cd3f13ee43b6cf7190c1894b5a88 SHA512 44bf3b845c9ef93cc539645765af63b037fc9e421f0a97c848946399de13c1d47df86efe63b0bb50fbd54a76912d3bcc7f7f972e7f77c491933d20243492a7f1
+DIST identify-2.2.4.tar.gz 100967 BLAKE2B 9473a157ce2aed13ed45d6e8d83b4510c40ae977406b9d7b211caa70c27d1850cf49da8848495841281b1f192b576d269a5372215effd7d89c9211e51d51151d SHA512 25e255fd62d0e75aafa7037085362b7bf2ba8ae142bfb11e0e20452d503d8ec3f90ec84c8ef8966fb021fe1054c226862b3ce99d2288ec9aaa758a8971d1c87a
+EBUILD identify-2.2.3.ebuild 526 BLAKE2B 8138f1b173a62887ec83a95a40a3a8e47f587bc2dcf80f4d82dd01400b812dd30258a134f5726025f8d1cfb1d977ad006e0c3f711af0e5df42279b7b6648c6be SHA512 146f06e9f358b9d826c9d8cdeb972353cb943bad82fe808322009543eb8fa9c4a80ef2abe89cb8b43bb58f261ba65cda415855bc6fc4c77c5faf878679af76e7
+EBUILD identify-2.2.4.ebuild 526 BLAKE2B 8138f1b173a62887ec83a95a40a3a8e47f587bc2dcf80f4d82dd01400b812dd30258a134f5726025f8d1cfb1d977ad006e0c3f711af0e5df42279b7b6648c6be SHA512 146f06e9f358b9d826c9d8cdeb972353cb943bad82fe808322009543eb8fa9c4a80ef2abe89cb8b43bb58f261ba65cda415855bc6fc4c77c5faf878679af76e7
+MISC metadata.xml 375 BLAKE2B 5f97fa87c1c286f77f578814baad9249203d07249c189e59e33353d34f91d1301c0055c5ec6a8374657e47609188e1da83cc8f420e72caa2e38a1f2f45e91ce1 SHA512 519958c4a7447a47d8c7e63349b989354513fd7c7f90256297486601752e8e8d00a233a353602ac0ad1240497fad69e4124efff72d1e4b21fffb690d68164024
diff --git a/dev-python/identify/identify-2.2.3.ebuild b/dev-python/identify/identify-2.2.3.ebuild
new file mode 100644
index 000000000000..302310afdfe1
--- /dev/null
+++ b/dev-python/identify/identify-2.2.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="https://github.com/pre-commit/identify"
+SRC_URI="https://github.com/pre-commit/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/editdistance-s[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
diff --git a/dev-python/identify/identify-2.2.4.ebuild b/dev-python/identify/identify-2.2.4.ebuild
new file mode 100644
index 000000000000..302310afdfe1
--- /dev/null
+++ b/dev-python/identify/identify-2.2.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="https://github.com/pre-commit/identify"
+SRC_URI="https://github.com/pre-commit/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/editdistance-s[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
diff --git a/dev-python/identify/metadata.xml b/dev-python/identify/metadata.xml
new file mode 100644
index 000000000000..aac3450e825e
--- /dev/null
+++ b/dev-python/identify/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pre-commit/identify</remote-id>
+ <remote-id type="pypi">identify</remote-id>
+ </upstream>
+</pkgmetadata>