summaryrefslogtreecommitdiff
path: root/dev-python/identify/identify-2.5.36.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-21 12:05:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-21 12:05:28 +0100
commit490ef2c2dc8b4e808f37add1adee21a754efd9a9 (patch)
treee235cdf15550b3d2f644b6fc4a8aa726971416f5 /dev-python/identify/identify-2.5.36.ebuild
parentda7ae1dd1fccb6b3c0e4763ab983ad96d57bf463 (diff)
gentoo auto-resync : 21:04:2024 - 12:05:28
Diffstat (limited to 'dev-python/identify/identify-2.5.36.ebuild')
-rw-r--r--dev-python/identify/identify-2.5.36.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/identify/identify-2.5.36.ebuild b/dev-python/identify/identify-2.5.36.ebuild
new file mode 100644
index 000000000000..0aa9daac20bc
--- /dev/null
+++ b/dev-python/identify/identify-2.5.36.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest