summaryrefslogtreecommitdiff
path: root/dev-python/identify/identify-2.5.24.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-04 11:28:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-04 11:28:04 +0100
commit47a1d2f184696819152c003a600beb058fbc4420 (patch)
treea85ea2840d8bb2bfaea292c4e2f363b663cc1ea1 /dev-python/identify/identify-2.5.24.ebuild
parent42564959cad787b3e82c0ebd8a8a6a59958e1370 (diff)
gentoo auto-resync : 04:05:2023 - 11:28:04
Diffstat (limited to 'dev-python/identify/identify-2.5.24.ebuild')
-rw-r--r--dev-python/identify/identify-2.5.24.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/identify/identify-2.5.24.ebuild b/dev-python/identify/identify-2.5.24.ebuild
new file mode 100644
index 000000000000..ee60b9635233
--- /dev/null
+++ b/dev-python/identify/identify-2.5.24.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest