summaryrefslogtreecommitdiff
path: root/dev-python/identify/identify-2.5.19.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-08 18:00:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-08 18:00:27 +0000
commit78ebdce6a16942c7081565472862ab6730321ee3 (patch)
tree91e2d66a20ff982c4ccfdb6e95573a0d4ad2b3df /dev-python/identify/identify-2.5.19.ebuild
parent0d96a0e47c83a107ad92e2bc90e5389f577cc9a4 (diff)
gentoo auto-resync : 08:03:2023 - 18:00:26
Diffstat (limited to 'dev-python/identify/identify-2.5.19.ebuild')
-rw-r--r--dev-python/identify/identify-2.5.19.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/identify/identify-2.5.19.ebuild b/dev-python/identify/identify-2.5.19.ebuild
new file mode 100644
index 000000000000..a0d521fdd551
--- /dev/null
+++ b/dev-python/identify/identify-2.5.19.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest