summaryrefslogtreecommitdiff
path: root/dev-python/hypothesis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-29 09:16:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-29 09:16:49 +0100
commitb2d3769042cfd3d8ceadaa52f6a5aafabb0d4114 (patch)
tree4fcc91b967ba153d4030d61e10f1b07b53755488 /dev-python/hypothesis
parent2d3042634af4767714cb90eff3f773ef54afb5ed (diff)
gentoo auto-resync : 29:05:2023 - 09:16:49
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest2
-rw-r--r--dev-python/hypothesis/hypothesis-6.75.6.ebuild12
2 files changed, 2 insertions, 12 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index e99598bb68f1..45282e69148d 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -3,5 +3,5 @@ DIST hypothesis-6.75.5.gh.tar.gz 9370565 BLAKE2B e9ef05cfc24a0e5ada5ba863b4ce4c2
DIST hypothesis-6.75.6.gh.tar.gz 9370713 BLAKE2B 93996d6ff0c109c11123ad9b653502c44d51277760338c2575840d6257081bb19b0eedbf2d0feb15e9ebc9e6feacdbe79e070bfd31d35bb9c825bb4a2d44b7f5 SHA512 12396799a7f3fe661f5cb72ccf1a7299919d9f4b05a4075810803350380d217e30312d853ba72e49c28c4f1a08143cb76adc87465ba9cef7400e2dad9cc52001
EBUILD hypothesis-6.75.3.ebuild 3332 BLAKE2B f8f40533ab1e341d563093f901fb42bbe290927d1579c201389e5c210d58dd883f5a9cd5819829b76c9cde8c6e0031a8a0234c99d0465855dd699e59b72d6a02 SHA512 f9fb85e22f3d7df7e5eeb0d6e09b5b4f294e281e222e7ddc80b0b92b92b7a6cd80a3eb4e6ee3eaa6b5ef1a2bd7248291e160c584b3d11b5b0a5649f01baca079
EBUILD hypothesis-6.75.5.ebuild 3392 BLAKE2B fb6424f2cc03ef7ae8806ba24f845896c3af5dbb55a52ff60e423f97bf9811a2cf1aca9568260ff75901595a8a8423cae319205c4c6a750510f4751e5019d178 SHA512 3d3ca613a80fb92cec796a1dbcfa3c7d3b1974d9efb7dd268f09a67de4835a6962e82ab88840da75025cea10123ae31807a4497a7523612b6483b78086538e4d
-EBUILD hypothesis-6.75.6.ebuild 3392 BLAKE2B fb6424f2cc03ef7ae8806ba24f845896c3af5dbb55a52ff60e423f97bf9811a2cf1aca9568260ff75901595a8a8423cae319205c4c6a750510f4751e5019d178 SHA512 3d3ca613a80fb92cec796a1dbcfa3c7d3b1974d9efb7dd268f09a67de4835a6962e82ab88840da75025cea10123ae31807a4497a7523612b6483b78086538e4d
+EBUILD hypothesis-6.75.6.ebuild 2835 BLAKE2B 7e0520e23b0672f1088e665e612a2217367753b04d54902ff23f1a94efe92e20bca52033f15eb031d81adacba6583d62fb8c8d87080d6b94c8aed0d67eb39ba7 SHA512 113550407eb5a6cde0bc1391f48d8cd2acb4d8c6423233740a55a1c5b569d3c91b55a739626a4a87546f22d2f37d304cc76d2949120b95ad74306b126f4cebe5
MISC metadata.xml 492 BLAKE2B c9e9bbd59af55d1f47e5b7a86933c02b47f832122d03eaca56bd3ec9476cf260d91d4fd2da5068845d4525b7cc9f702b515e8d6a0dffa7923f5898cfd44e12a1 SHA512 166b33d6ac887f52d54fb9d556102038c00650a597d2de1c3aad3f8b5e136e9b6b7db31f05f3379435e4c5f943156d5839d78fc95461af411037a3162ea6705e
diff --git a/dev-python/hypothesis/hypothesis-6.75.6.ebuild b/dev-python/hypothesis/hypothesis-6.75.6.ebuild
index 73f0790f2dd8..151e8872fdec 100644
--- a/dev-python/hypothesis/hypothesis-6.75.6.ebuild
+++ b/dev-python/hypothesis/hypothesis-6.75.6.ebuild
@@ -67,20 +67,10 @@ python_test() {
)
fi
if [[ ${EPYTHON} == python3.12 ]]; then
- # these look serious but affect hypothesis only partially,
- # i.e. many revdeps will still work and since this is a test dep,
- # we don't need it 100% perfect
- # https://github.com/python/cpython/issues/105013
- EPYTEST_IGNORE+=(
- tests/cover/test_type_lookup.py
- )
EPYTEST_DESELECT+=(
- hypothesis-python/tests/cover/test_complex_numbers.py::test_allow_subnormal
- hypothesis-python/tests/cover/test_lambda_formatting.py::test_can_get_descriptions_of_nested_lambdas_with_different_names
hypothesis-python/tests/cover/test_lookup.py
- hypothesis-python/tests/cover/test_targeting.py::test_disallowed_inputs_to_target
+ hypothesis-python/tests/cover/test_type_lookup.py
hypothesis-python/tests/cover/test_type_lookup_forward_ref.py
- hypothesis-python/tests/cover/test_uuids.py
hypothesis-python/tests/quality/test_discovery_ability.py::test_one_of_flattens_filter_branches_{1..3}
)
fi