summaryrefslogtreecommitdiff
path: root/dev-python/hypothesis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-24 15:02:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-24 15:02:35 +0100
commit59c803bef0bf9b4f167918783e386c3ddb746751 (patch)
treee57c71b0e5edaa64821fa7862dd9f8ba9c1030f0 /dev-python/hypothesis
parentbd2c7873be3178619accade4259ba907b6baca46 (diff)
gentoo auto-resync : 24:05:2023 - 15:02:35
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest2
-rw-r--r--dev-python/hypothesis/hypothesis-6.75.3.ebuild23
2 files changed, 21 insertions, 4 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 09792e852bfd..f94b0a2eeff5 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,3 +1,3 @@
DIST hypothesis-6.75.3.gh.tar.gz 9369491 BLAKE2B bae51e4f280a0773d4101b5b136ad994cb7eaca64a0a030bf3a9346d15a3caf7864bfc2f92bdff9eaabe83abc492b7e6cf31b19771470f6d680dbea9c83b31a4 SHA512 2e31f2f5483abf4c749dc3ef2758e51b62072e36f257777cecd71ea8f67a08987f5547bc9476dd2dbf8e9a6488fbe76d3d8ae83666bc2e80a2f26ea807cb15aa
-EBUILD hypothesis-6.75.3.ebuild 2454 BLAKE2B b70bf8f5c34ae420af4aa0b36e62e34141f1c24184892a2567372955a9ddc8c905621288152c449833eb5d3e8f061c7141f44f219b9d767265acab2faa4d5a72 SHA512 e6399b91932c32b5396b8dbbd94e00abec1287cdba57dfdaa6941c74bff625db429b33121ac25bb13a1ceb766a1bc721e91138e5695d8d934f0df2226a64b1d4
+EBUILD hypothesis-6.75.3.ebuild 3332 BLAKE2B f8f40533ab1e341d563093f901fb42bbe290927d1579c201389e5c210d58dd883f5a9cd5819829b76c9cde8c6e0031a8a0234c99d0465855dd699e59b72d6a02 SHA512 f9fb85e22f3d7df7e5eeb0d6e09b5b4f294e281e222e7ddc80b0b92b92b7a6cd80a3eb4e6ee3eaa6b5ef1a2bd7248291e160c584b3d11b5b0a5649f01baca079
MISC metadata.xml 492 BLAKE2B c9e9bbd59af55d1f47e5b7a86933c02b47f832122d03eaca56bd3ec9476cf260d91d4fd2da5068845d4525b7cc9f702b515e8d6a0dffa7923f5898cfd44e12a1 SHA512 166b33d6ac887f52d54fb9d556102038c00650a597d2de1c3aad3f8b5e136e9b6b7db31f05f3379435e4c5f943156d5839d78fc95461af411037a3162ea6705e
diff --git a/dev-python/hypothesis/hypothesis-6.75.3.ebuild b/dev-python/hypothesis/hypothesis-6.75.3.ebuild
index 017a26484d47..fef5bdcef671 100644
--- a/dev-python/hypothesis/hypothesis-6.75.3.ebuild
+++ b/dev-python/hypothesis/hypothesis-6.75.3.ebuild
@@ -4,8 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-CLI_COMPAT=( python3_{9..11} )
-PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 )
+CLI_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_12 pypy3 )
PYTHON_REQ_USE="threads(+),sqlite"
inherit distutils-r1 multiprocessing optfeature
@@ -59,13 +59,30 @@ python_test() {
# NB: paths need to be relative to pytest.ini,
# i.e. start with hypothesis-python/
- local EPYTEST_DESELECT=()
+ local EPYTEST_DESELECT=() EPYTEST_IGNORE=()
if [[ ${EPYTHON} == pypy3 ]]; then
EPYTEST_DESELECT+=(
# failing due to warnings from numpy/cython
hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
)
fi
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ # these look serious but affect hypothesis only partially,
+ # i.e. many revdeps will still work and since this is a test dep,
+ # we don't need it 100% perfect
+ EPYTEST_IGNORE+=(
+ tests/cover/test_type_lookup.py
+ )
+ EPYTEST_DESELECT+=(
+ hypothesis-python/tests/cover/test_complex_numbers.py::test_allow_subnormal
+ hypothesis-python/tests/cover/test_lambda_formatting.py::test_can_get_descriptions_of_nested_lambdas_with_different_names
+ hypothesis-python/tests/cover/test_lookup.py
+ hypothesis-python/tests/cover/test_targeting.py::test_disallowed_inputs_to_target
+ hypothesis-python/tests/cover/test_type_lookup_forward_ref.py
+ hypothesis-python/tests/cover/test_uuids.py
+ hypothesis-python/tests/quality/test_discovery_ability.py::test_one_of_flattens_filter_branches_{1..3}
+ )
+ fi
epytest -o filterwarnings= -n "$(makeopts_jobs)" \
tests/cover tests/pytest tests/quality