summaryrefslogtreecommitdiff
path: root/dev-python/hyperlink
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/hyperlink
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/hyperlink')
-rw-r--r--dev-python/hyperlink/Manifest3
-rw-r--r--dev-python/hyperlink/hyperlink-17.1.1.ebuild31
-rw-r--r--dev-python/hyperlink/metadata.xml25
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/hyperlink/Manifest b/dev-python/hyperlink/Manifest
new file mode 100644
index 000000000000..5509a2f6a80e
--- /dev/null
+++ b/dev-python/hyperlink/Manifest
@@ -0,0 +1,3 @@
+DIST hyperlink-17.1.1.tar.gz 23067 SHA256 a7462dee03672b8f853c26e1ab9e3b1fd4c90a6efde64ab44a851c2472445018 SHA512 13b20fd54c6bb5d7de3c9a04133fdd848413d1308d9944a2288c76d5f8b9bb0c54401ca5ed53460112209806407497526f2e68a92d119656eb58a9a618e9b708 WHIRLPOOL 86f3dab9cd32805ce974d55920ab3a4cad032da740ce3e4fb103b20ee59a501400e302aa6c90f7d905bb49b78a460a4187a21fe34dc3a155b9234f6e48ea11f1
+EBUILD hyperlink-17.1.1.ebuild 746 SHA256 f831d9c269d4b5f1a8abccb6511f102edf6238238d63182386cfcf4b1494ad04 SHA512 d683637d349fe8455d7125d9681d2d37cdf8e199090cff6df6ddd90b8924000dfc528eab404843993ad42a0ffa083e562b24a9239da974f2af1795e48cdf8f9f WHIRLPOOL 765f689e079e84a1dbc496395c7c9749415fb7cac0aeb465369eb86bef82e760f608832b62d41bfb1bbcb109957045e919b512148e860ad8ef17655448a339ab
+MISC metadata.xml 799 SHA256 c71176540b5977a518a64d2d02d796d3af881f1526e128214fa8c71bbf5d9aee SHA512 be631c718eadd3957f4152a6f630f67b0b308067b1bcdf4a9c6618edddfbd6eba61f6e8ff11fe45ed90cd77fefbf360a9f30baa01e5ff1cf703fd3dc59feb734 WHIRLPOOL 7fba5f4310378a6a7aae961abcfd21a540bdd63f062ac1b2d1662491597bb4a13383d6f9655ef71114df3098ac79fd94a8f4c870f348e6b505ed40802edfe0d5
diff --git a/dev-python/hyperlink/hyperlink-17.1.1.ebuild b/dev-python/hyperlink/hyperlink-17.1.1.ebuild
new file mode 100644
index 000000000000..9e2620d13d17
--- /dev/null
+++ b/dev-python/hyperlink/hyperlink-17.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="A featureful, correct URL for Python"
+HOMEPAGE="https://github.com/python-hyper/hyperlink https://pypi.python.org/pypi/hyperlink"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.3.0[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
+ py.test -v || die
+ cd test
+}
diff --git a/dev-python/hyperlink/metadata.xml b/dev-python/hyperlink/metadata.xml
new file mode 100644
index 000000000000..ddf1f449113f
--- /dev/null
+++ b/dev-python/hyperlink/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>mahmoud@hatnote.com</email>
+ <name>Mahmoud Hashemi</name>
+ </maintainer>
+ <remote-id type="pypi">hyperframe</remote-id>
+ </upstream>
+ <longdescription>
+ The humble, but powerful, URL runs everything around us.
+ Chances are you've used several just to read this text.
+ Hyperlink is a featureful, pure-Python implementation of the URL, with
+ an emphasis on correctness.
+ </longdescription>
+</pkgmetadata>