summaryrefslogtreecommitdiff
path: root/dev-python/hyperlink/hyperlink-18.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/hyperlink/hyperlink-18.0.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/hyperlink/hyperlink-18.0.0.ebuild')
-rw-r--r--dev-python/hyperlink/hyperlink-18.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/hyperlink/hyperlink-18.0.0.ebuild b/dev-python/hyperlink/hyperlink-18.0.0.ebuild
new file mode 100644
index 000000000000..6eb930d31077
--- /dev/null
+++ b/dev-python/hyperlink/hyperlink-18.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="A featureful, correct URL for Python"
+HOMEPAGE="https://github.com/python-hyper/hyperlink https://pypi.org/project/hyperlink/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ pytest -vv || die
+}