summaryrefslogtreecommitdiff
path: root/dev-python/hyperframe/hyperframe-6.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/hyperframe/hyperframe-6.0.0.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/hyperframe/hyperframe-6.0.0.ebuild')
-rw-r--r--dev-python/hyperframe/hyperframe-6.0.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/hyperframe/hyperframe-6.0.0.ebuild b/dev-python/hyperframe/hyperframe-6.0.0.ebuild
new file mode 100644
index 000000000000..7337c2d4dc4f
--- /dev/null
+++ b/dev-python/hyperframe/hyperframe-6.0.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP/2 framing layer for Python"
+HOMEPAGE="https://python-hyper.org/en/latest/
+ https://pypi.org/project/hyperframe/
+ https://github.com/python-hyper/hyperframe"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest