summaryrefslogtreecommitdiff
path: root/dev-python/hvac/hvac-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-16 11:14:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-16 11:14:46 +0100
commitacb0389058b8ef612d851b1ab54fa37376c4b7f7 (patch)
treeb1e68406cfd137e951d13c4307e3c2fac7ae0087 /dev-python/hvac/hvac-1.0.0.ebuild
parent121b314457e147271cd95353cf8886d35b329845 (diff)
gentoo auto-resync : 16:09:2022 - 11:14:45
Diffstat (limited to 'dev-python/hvac/hvac-1.0.0.ebuild')
-rw-r--r--dev-python/hvac/hvac-1.0.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/hvac/hvac-1.0.0.ebuild b/dev-python/hvac/hvac-1.0.0.ebuild
new file mode 100644
index 000000000000..50300776b3be
--- /dev/null
+++ b/dev-python/hvac/hvac-1.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="hashicorp vault client in python"
+HOMEPAGE="https://github.com/hvac/hvac"
+SRC_URI="https://github.com/hvac/hvac/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pyhcl-0.4.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/jwcrypto[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/semantic_version[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # ldap_test is not packaged.
+ tests/integration_tests/api/auth_methods/test_ldap.py
+ # https://github.com/lepture/authlib is not packaged.
+ tests/integration_tests/api/auth_methods/test_oidc.py
+)