summaryrefslogtreecommitdiff
path: root/dev-python/humanize
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/humanize
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/humanize')
-rw-r--r--dev-python/humanize/Manifest4
-rw-r--r--dev-python/humanize/humanize-0.5.1.ebuild37
-rw-r--r--dev-python/humanize/metadata.xml17
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
new file mode 100644
index 000000000000..701c8b19d186
--- /dev/null
+++ b/dev-python/humanize/Manifest
@@ -0,0 +1,4 @@
+DIST humanize-0.5.1.tar.gz 20507 SHA256 e3f3ac75e647f75eec48c3950385ab7585c1c1cde2a6c1479c1f58e055a3e868 SHA512 dd7ad7f3c564cc6abcb6b128e50dbea7f19f7f418bfd936aae2472961c53ec71202133c5c2b5b930ef41ef807b51d6ba1210565627ed32c0b41acc0abd32a2d5 WHIRLPOOL 37a43b9dc5e7d4b2054453f45d663af630b598f017e18b937aaa7265ca97e75dd8219eaab276710d3f906ffb0330b69eb9642046f17d7f5a321c3e214fb65617
+EBUILD humanize-0.5.1.ebuild 867 SHA256 3626f3570a24e6438aa0f1ceedbb8a4498d2e853a40d78537607c2da062900d2 SHA512 a57f2e4ab378f9de3a60e0b89b8c73a98188082f06077c583c862e441a41b83a0d092ce33afd3ea6c0838d54203f0c855f6f6e4cf166ab7a978368654c964768 WHIRLPOOL d12245c848ac7e57933cc5fc1f0217a66bb8893c0b9e7d51ad9a54d063e737ed139c4f48aeb19113e61192b55c9cc8b90454dbda3b9febc73a354e20a1a47432
+MISC ChangeLog 452 SHA256 b5a35f96de7031d8373c0cfff376c9f899f1e2d411d7a7ff5edfca60e9842c63 SHA512 4b1e9ba9dd709d01027ce6cbebf1721fb5d1ba0a7219c37151d2ea9229b980ce82a75ffe699fb88edd6c3a3d7c0696893f06fb54693765601c2bdefb8c93d9a9 WHIRLPOOL 7c368ebe3f1e95340de852007a613f0940820f13e4a3cb5a8366b05b49fb11a5349bd068823082fcce00e234ddab38cd93fc91ccd788278c69f19589bb5fd494
+MISC metadata.xml 560 SHA256 26c01f3b4ff01d74c48189ec3e345a68456f03f5175affc3ea0f83d82c851a44 SHA512 671661f3da4180319c2ce22e8bf9d49173fca8ea51136ab97af91b4a3667a2c241df610c61e5ccd4304511abf4dd47f3e878bbdb463e7ba2316dfb0df09e36be WHIRLPOOL fcc80156a90dfad4e7aa5cdde9b946ebf5aa1b2e7fd11bfd0c1ab818dc55feecc876419f7bd3dcd588639087baa01ef32d0cc6bafbe839a0f87ba5c8f3e61571
diff --git a/dev-python/humanize/humanize-0.5.1.ebuild b/dev-python/humanize/humanize-0.5.1.ebuild
new file mode 100644
index 000000000000..cddd0815cf3a
--- /dev/null
+++ b/dev-python/humanize/humanize-0.5.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+# Tests are not included in PyPI tarballs
+# https://github.com/jmoiron/humanize/issues/33
+SRC_URI="https://github.com/jmoiron/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+ if use doc; then
+ cd docs || die
+ sphinx-build . _build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ esetup.py test || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/humanize/metadata.xml b/dev-python/humanize/metadata.xml
new file mode 100644
index 000000000000..1957b0b12307
--- /dev/null
+++ b/dev-python/humanize/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">humanize</remote-id>
+ <remote-id type="github">jmoiron/humanize</remote-id>
+ <bugs-to>https://github.com/jmoiron/humanize/issues</bugs-to>
+ </upstream>
+</pkgmetadata>