summaryrefslogtreecommitdiff
path: root/dev-python/humanize
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/humanize
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/humanize')
-rw-r--r--dev-python/humanize/Manifest3
-rw-r--r--dev-python/humanize/humanize-0.5.1.ebuild37
-rw-r--r--dev-python/humanize/metadata.xml13
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
new file mode 100644
index 000000000000..a6dda7ba688a
--- /dev/null
+++ b/dev-python/humanize/Manifest
@@ -0,0 +1,3 @@
+DIST humanize-0.5.1.tar.gz 20507 BLAKE2B 55d7b598b32658b1d4c4741b37b5c33bdc9d63a5a779455e2fb93e1e4c3a0d8fd58e8522ef82734e1ba2b161fd881829373ba3569baffd9ea3271ad7ed3e7568 SHA512 dd7ad7f3c564cc6abcb6b128e50dbea7f19f7f418bfd936aae2472961c53ec71202133c5c2b5b930ef41ef807b51d6ba1210565627ed32c0b41acc0abd32a2d5
+EBUILD humanize-0.5.1.ebuild 867 BLAKE2B 99079dc11347c81d989c88ad56d5cc642ab6f1267fa7b6ddf09805fb3844901c84950a6169c81934b59129ff6a37bd3196fd0213a0b9921431eb005db7959dd1 SHA512 a57f2e4ab378f9de3a60e0b89b8c73a98188082f06077c583c862e441a41b83a0d092ce33afd3ea6c0838d54203f0c855f6f6e4cf166ab7a978368654c964768
+MISC metadata.xml 436 BLAKE2B 79f8554b22e171509667145d3270ea7068ff215fc9d999f2cf654cf42948ba49f850efcdb19cb2a3fb41347612a4d3f178c529410b42238555b20b652b40900f SHA512 871a75a8295b80f9884f191f2264329be5a2975429e35b1ded2e085771284cfa76e230d2e7784a05524ec51cb809fde24e34d6caea45904f5fed3b388fe855a2
diff --git a/dev-python/humanize/humanize-0.5.1.ebuild b/dev-python/humanize/humanize-0.5.1.ebuild
new file mode 100644
index 000000000000..cddd0815cf3a
--- /dev/null
+++ b/dev-python/humanize/humanize-0.5.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+# Tests are not included in PyPI tarballs
+# https://github.com/jmoiron/humanize/issues/33
+SRC_URI="https://github.com/jmoiron/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+ if use doc; then
+ cd docs || die
+ sphinx-build . _build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ esetup.py test || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/humanize/metadata.xml b/dev-python/humanize/metadata.xml
new file mode 100644
index 000000000000..0e99920654d2
--- /dev/null
+++ b/dev-python/humanize/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sbraz@gentoo.org</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">humanize</remote-id>
+ <remote-id type="github">jmoiron/humanize</remote-id>
+ <bugs-to>https://github.com/jmoiron/humanize/issues</bugs-to>
+ </upstream>
+</pkgmetadata>