summaryrefslogtreecommitdiff
path: root/dev-python/humanfriendly
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-python/humanfriendly
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-python/humanfriendly')
-rw-r--r--dev-python/humanfriendly/Manifest4
-rw-r--r--dev-python/humanfriendly/humanfriendly-9.1.ebuild36
-rw-r--r--dev-python/humanfriendly/metadata.xml1
3 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/humanfriendly/Manifest b/dev-python/humanfriendly/Manifest
index 7d76d27592e6..45ec8b5dfcb5 100644
--- a/dev-python/humanfriendly/Manifest
+++ b/dev-python/humanfriendly/Manifest
@@ -1,3 +1,5 @@
DIST humanfriendly-8.2.tar.gz 358747 BLAKE2B bc5824e94ea94df6ee93ea44d273ccb856f50b69e52ae6293afaedf06c9f00c67e064f0c85edd88be9954bb258334b1b9af4ab88efc5b352f3efe8d322fc55c1 SHA512 123d8592e6613a70421740648bb8998733b118927a0bd6182af848612e46eec8e35cae95168219c9b7672bed8e18e1c4a493a80248eabe47f8a4cb1813c8b591
+DIST humanfriendly-9.1.tar.gz 359616 BLAKE2B c67ca9498ff4a0dac237c8f1c81ae88882a7ab162e2cfd663cd50a066dbcfe045424bdf4dcc1df473f5fc41f0c1b8c0f2aca9883aa21915281618ba332c579a3 SHA512 859a9ff01abe0671a23a63e73c9c09c0f92151e96ec38dd5695c75f99fa436e186835cb8a16f59b82d5216b9c427ea0abd419b470b067f8032fe984776f02a8f
EBUILD humanfriendly-8.2.ebuild 898 BLAKE2B ed741abb4d4ad5dd59105f707d8dc83e26f16313c62cc9b7beb579924419f35ae346b20fbb867a4954b72c20be5fbac63b73d4c976c6bb75a7a1fceb31f9edf4 SHA512 07fbc9678d7916ff20a70deb4a00194cfebadab778ac8b6c19d1dc751745e24d174410e5c0cf6208f2eaaef7921feb53103dd8266d647b1ead49a4362488c63b
-MISC metadata.xml 382 BLAKE2B dfc1cffeb957908577b82b8014b01d8be706755bbeb701dc5f8d117685bc720bf540722d0d61f47224221331af6237c5acd5c899298e5e29837fd3be3b27fa23 SHA512 4a90e529dc08af1b8701b69618ab8459a35417c33ca70fa024b3a2a7c1c7a1b156b566f4c5d18623d588c06f63f1a56208f50d675667a670d897c40a1b769cbe
+EBUILD humanfriendly-9.1.ebuild 897 BLAKE2B aa4f3a4dc7956bbf09e4e3c44e9a697a94e9f9e216440d36c780658dd729a211881dde7cd8a84b602924393605e4b7facfabf0e8e975e0b0e4092115bf8aca94 SHA512 5c68cd3fa187c9107ba02c5120a2af7d8bb8d576472ac518f2098286c4b4525310acee68113a60f4de4a439681582da3efa9bd2dbcda889bcc1aea0233ba680f
+MISC metadata.xml 406 BLAKE2B 974edaa1c5189ede8c81989c21436b45d53cf5d92e1b2b49a6731f68d098410966685f5184eda0e55191c441390a8f3f9869ae945425655b559dae160d99ba19 SHA512 86b4ff000469fd0edd3c089b725d3e2144be2f56fb5f2ccc3f4e936a5a12c8c45b2a4ac8cc1857c8c14d54fcc04717e2bd7effc7ff6d728f9033d41856095096
diff --git a/dev-python/humanfriendly/humanfriendly-9.1.ebuild b/dev-python/humanfriendly/humanfriendly-9.1.ebuild
new file mode 100644
index 000000000000..9ba2dcee001c
--- /dev/null
+++ b/dev-python/humanfriendly/humanfriendly-9.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Human friendly output for text interfaces using Python"
+HOMEPAGE="https://pypi.org/project/humanfriendly/
+ https://github.com/xolox/python-humanfriendly/
+ https://humanfriendly.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/capturer[${PYTHON_USEDEP}]
+ dev-python/coloredlogs[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_test() {
+ pytest -vv ${PN}/tests.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/humanfriendly/metadata.xml b/dev-python/humanfriendly/metadata.xml
index 963d1abe79b3..16360517e2a3 100644
--- a/dev-python/humanfriendly/metadata.xml
+++ b/dev-python/humanfriendly/metadata.xml
@@ -5,6 +5,7 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">humanfriendly</remote-id>
<remote-id type="github">xolox/python-humanfriendly</remote-id>