summaryrefslogtreecommitdiff
path: root/dev-python/httpx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/httpx
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/httpx')
-rw-r--r--dev-python/httpx/Manifest5
-rw-r--r--dev-python/httpx/httpx-0.16.1.ebuild45
-rw-r--r--dev-python/httpx/httpx-0.17.0.ebuild45
-rw-r--r--dev-python/httpx/metadata.xml14
4 files changed, 109 insertions, 0 deletions
diff --git a/dev-python/httpx/Manifest b/dev-python/httpx/Manifest
new file mode 100644
index 000000000000..c821cff3c6d2
--- /dev/null
+++ b/dev-python/httpx/Manifest
@@ -0,0 +1,5 @@
+DIST httpx-0.16.1.tar.gz 965347 BLAKE2B a6c5bcdda595ffcfb824194564ebd93760a9180e60665a9540fc6a2822b1be4273b940fee61cb4b49c2d97a5f4d71b1caf32deddec18d2fb636465b3868aece4 SHA512 d76b2c94c655c187ab150f20b16906034574d017a67c4a06c456d55071434cc0ba7752bdceda86aa6b1a1fe9109fa11594e4ea679cd7d2a77898fb40fa5153d3
+DIST httpx-0.17.0.tar.gz 1651681 BLAKE2B 46eec46d5f2006667ab51e5e4d98c1a22783351d9e2fa50ccab2431bf6e52dd9b124d50b32f151fc171561c913d879cfec4f717ea22fd2a333c13190368ab505 SHA512 9471c404c02481a10d42e10e36a55cd55cdecd2cd98a8f3ca1f453a7f1ad7f1ce3b292b8fe583b1c95119f27c0b2eefc756b4e4ed353e3383c12009f3bde21cd
+EBUILD httpx-0.16.1.ebuild 1208 BLAKE2B 1764d1e6100c2b2b6412d157137d7b87501897140f8881052db73f6812afb642c23f4ed03365ab3daf6c223625a4d6d7179c4189fd8239fde232cfa2cce5f4e5 SHA512 086f4195cd49cd102d95f7e83add82dd4027b5e6b6b71b858501e058659432b9823b5208aa7e13aac30dc17b69a377624f86f9d313c07e3a460d3443c62e263a
+EBUILD httpx-0.17.0.ebuild 1208 BLAKE2B 1764d1e6100c2b2b6412d157137d7b87501897140f8881052db73f6812afb642c23f4ed03365ab3daf6c223625a4d6d7179c4189fd8239fde232cfa2cce5f4e5 SHA512 086f4195cd49cd102d95f7e83add82dd4027b5e6b6b71b858501e058659432b9823b5208aa7e13aac30dc17b69a377624f86f9d313c07e3a460d3443c62e263a
+MISC metadata.xml 444 BLAKE2B 62369fdf937f8caf46980620f2da0b16512ef94cbea9fecf0c336029a709e0975332d0d4e53ff4f3eeddeb9d231a5003dff9bbdf999846152bf578772b47d9a9 SHA512 bbbc7e622f0aae3b63e19765626ee13adf027d5ed98ca97fe04592b1f0a8da0cd0302b31f9cda90eaacf2bf5dad9c6472ddd795db75f0992ba4f084e4135ea3d
diff --git a/dev-python/httpx/httpx-0.16.1.ebuild b/dev-python/httpx/httpx-0.16.1.ebuild
new file mode 100644
index 000000000000..aff93e055f9e
--- /dev/null
+++ b/dev-python/httpx/httpx-0.16.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fully-featured HTTP client which provides sync and async APIs"
+HOMEPAGE="https://www.python-httpx.org/"
+SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/sniffio[${PYTHON_USEDEP}]
+ =dev-python/httpcore-0.12*[${PYTHON_USEDEP}]
+ >=dev-python/rfc3986-1.3[${PYTHON_USEDEP}]
+ <dev-python/rfc3986-2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/brotlipy[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/hyper-h2[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/uvicorn[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Require Internet access
+ sed -i 's/test_async_proxy_close\|test_sync_proxy_close/_&/' \
+ tests/client/test_proxies.py || die
+ # trio is not currently in the tree
+ sed -i '/^import trio/d' tests/concurrency.py || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/httpx/httpx-0.17.0.ebuild b/dev-python/httpx/httpx-0.17.0.ebuild
new file mode 100644
index 000000000000..aff93e055f9e
--- /dev/null
+++ b/dev-python/httpx/httpx-0.17.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fully-featured HTTP client which provides sync and async APIs"
+HOMEPAGE="https://www.python-httpx.org/"
+SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/sniffio[${PYTHON_USEDEP}]
+ =dev-python/httpcore-0.12*[${PYTHON_USEDEP}]
+ >=dev-python/rfc3986-1.3[${PYTHON_USEDEP}]
+ <dev-python/rfc3986-2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/brotlipy[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/hyper-h2[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/uvicorn[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Require Internet access
+ sed -i 's/test_async_proxy_close\|test_sync_proxy_close/_&/' \
+ tests/client/test_proxies.py || die
+ # trio is not currently in the tree
+ sed -i '/^import trio/d' tests/concurrency.py || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/httpx/metadata.xml b/dev-python/httpx/metadata.xml
new file mode 100644
index 000000000000..f5203f06f339
--- /dev/null
+++ b/dev-python/httpx/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">httpx</remote-id>
+ <remote-id type="github">encode/httpx</remote-id>
+ <bugs-to>https://github.com/encode/httpx/issues</bugs-to>
+ </upstream>
+</pkgmetadata>