summaryrefslogtreecommitdiff
path: root/dev-python/httpx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-20 19:51:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-20 19:51:59 +0000
commit1fb8608d6f0b1acf0e34361c105533087a09c710 (patch)
tree5c247db22c44a72ff61ecd68477ed3d7ee357cb8 /dev-python/httpx
parentaec6329fe6b56821fd643ccaacb4d5d61f4eaad6 (diff)
gentoo auto-resync : 20:12:2023 - 19:51:59
Diffstat (limited to 'dev-python/httpx')
-rw-r--r--dev-python/httpx/Manifest2
-rw-r--r--dev-python/httpx/httpx-0.26.0.ebuild83
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/httpx/Manifest b/dev-python/httpx/Manifest
index 186ca257fcc3..c152cfbf7306 100644
--- a/dev-python/httpx/Manifest
+++ b/dev-python/httpx/Manifest
@@ -1,3 +1,5 @@
DIST httpx-0.25.2.gh.tar.gz 2162693 BLAKE2B 8ae9fd692341ae3224c73c1f6837489819df1a00e13702a7af72143bf291cfcae23807fd51a6e1092672d0b5595f9557084151f3d07fbdd4e7fce8f5860a879f SHA512 7e62fcea55b7d0710f6d50581c8dd1ff5ae594a673a9b1cea5c03487eb3402ca96d44c311a9bcef14f20a7faa03462a3fab07edfe1ce2b11ecd66e4f7e1a06d5
+DIST httpx-0.26.0.gh.tar.gz 2164373 BLAKE2B 1de507dd1a0a4f5c87187645f7928f37f29e9a6cdcaacfbefe0e324cda5ad7f86a29efe99b496629a2e2f14851b8a6312d8be4595cfc61a97ce302b284dd1939 SHA512 76838d5c191700f5fd4c6afcc9d129f3809811f6ce40d45edf89518457a9497cdd94c11a68a9c42494780c579eaa43760a8bd85313d7864a8f5ae1c1b9912d61
EBUILD httpx-0.25.2.ebuild 2157 BLAKE2B 253a24e8f98610d615f5f448d637eb7ca7d77f91c3fbae07192bb723ce80d118c6c2440fe0ddfb5eb08d14d6bdc2fb62346a654128ca84a1f346b28e04d25869 SHA512 6cb62a2c48755b32072cc1a11d0b185bc022858fc555209b6d89a317bae84d291bf965b84c74ee1c39f05abe14b0638f7f3c1cf196c3df5b95cb86619a50cf3c
+EBUILD httpx-0.26.0.ebuild 2027 BLAKE2B 1aa331402f0a0b63ea3a181183fbfcb5964a95ec774877f6123e54a959abecb42df47a4cfd77d221937818e7aaeeea32be197a10f94332c6090158ec7d618ab7 SHA512 ad33f97ed1ef7597414c9bc8102976a5d50319036b51fdc7b034b6ed3fea300af02b3b7958f7eb2adcbe98fd187ef98835530be9c6a1db951a49206350237c15
MISC metadata.xml 518 BLAKE2B 063b5b95529cd5a31aac83998c0acbdfef208c34e931c96ae8ee767a326301a597a8297514b5c97bef2b3b706b8938d38c0e5f5d752307a9dd06984792c799a2 SHA512 3a29dffa0f951255a67468b28917590d4108ca12e14af03bfddef80f6d48e266fcccdd991e778ab9e267c0bc76ff0017e07905c1f2f45dc440a9af89f6cae6aa
diff --git a/dev-python/httpx/httpx-0.26.0.ebuild b/dev-python/httpx/httpx-0.26.0.ebuild
new file mode 100644
index 000000000000..c6d702cbd883
--- /dev/null
+++ b/dev-python/httpx/httpx-0.26.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Fully-featured HTTP client which provides sync and async APIs"
+HOMEPAGE="
+ https://www.python-httpx.org/
+ https://github.com/encode/httpx/
+ https://pypi.org/project/httpx/
+"
+SRC_URI="
+ https://github.com/encode/httpx/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ dev-python/anyio[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ =dev-python/httpcore-1*[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/sniffio[${PYTHON_USEDEP}]
+ cli? (
+ =dev-python/click-8*[${PYTHON_USEDEP}]
+ =dev-python/pygments-2*[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ test? (
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/h2[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/uvicorn[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ if ! use cli; then
+ sed -i -e '/^httpx =/d' pyproject.toml || die
+ fi
+ sed -i -e '/rich/s:,<14::' pyproject.toml || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/client/test_proxies.py::test_async_proxy_close
+ tests/client/test_proxies.py::test_sync_proxy_close
+ )
+
+ use cli || EPYTEST_IGNORE+=(
+ tests/test_main.py
+ )
+
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "HTTP/2 support" dev-python/h2
+ optfeature "SOCKS proxy support" dev-python/socksio
+ optfeature "Decoding for brotli compressed responses" dev-python/brotlicffi
+}