summaryrefslogtreecommitdiff
path: root/dev-python/httpx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/httpx
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/httpx')
-rw-r--r--dev-python/httpx/Manifest4
-rw-r--r--dev-python/httpx/httpx-0.23.0.ebuild (renamed from dev-python/httpx/httpx-0.22.0-r2.ebuild)22
2 files changed, 13 insertions, 13 deletions
diff --git a/dev-python/httpx/Manifest b/dev-python/httpx/Manifest
index ced28b926136..b6650a0114b8 100644
--- a/dev-python/httpx/Manifest
+++ b/dev-python/httpx/Manifest
@@ -1,3 +1,3 @@
-DIST httpx-0.22.0.gh.tar.gz 2157682 BLAKE2B bb08a7c4b72478d24264c0dca5630205ff386af73294dca66dcd12b646de602ad64e308feedaabd58742cb7a9d799fa23cd2f922e685e74f8181e1b5e9f1c4ee SHA512 a7360f5355f75f07425b42d49697e480319f3fe606d4601bb6d64b870c8a8fce6fad8bd857ef422fc48e6141201307ee94876d5bc54a68557c7dc32ce8f1451b
-EBUILD httpx-0.22.0-r2.ebuild 2378 BLAKE2B f8e1f9476ccb1b38e5c410be27e7c91814bc74645b94663e9afd5e9eb987706a8c446f3e0e369cd0e956b8131e5573c7c9623337b35922fe24cf5ce33be0bdaf SHA512 323fce968823d40ee3a352efa17e3f9ef304c99310b4c0728a8a900db0bb89457793765d138d3708af6c8dd3f99d0c1ff6b53d6346c917eccb40f8bf7b9bf2b8
+DIST httpx-0.23.0.gh.tar.gz 2160686 BLAKE2B 036c66b2c3f743cd069716297f331f0d75043a98180b9db3e156c5692ae8bf9c68d1db87169953a7f44aaf7ee8554d0166f70b508f77b7ff4b0ebc0500bc02ad SHA512 3cfdf2b3b2f15967a1eec0be05ed947c5e18a46576b68a9cbfd5147dfd4736cb7c389f5431732b93f3a11f3ec6c6f25f7cbb3d96d845f00b58e2b8dae047c1d5
+EBUILD httpx-0.23.0.ebuild 2188 BLAKE2B c7ec73ae670465bdeac0d1b81543aca3d7652f54bd92fe80be7a158bec35a817764c3cee406fa8aab50f98869ff59f8321a19c1141f1eff0512b3579fede6e87 SHA512 9d400fe37329144efee52f6ad9f23317e5290ce0a0489a9cbb8573a88decc9aaf5a1f30233a7f0ffb0d122c59d764070c0b19951ace5473a3bba1b3da9ba666a
MISC metadata.xml 518 BLAKE2B 063b5b95529cd5a31aac83998c0acbdfef208c34e931c96ae8ee767a326301a597a8297514b5c97bef2b3b706b8938d38c0e5f5d752307a9dd06984792c799a2 SHA512 3a29dffa0f951255a67468b28917590d4108ca12e14af03bfddef80f6d48e266fcccdd991e778ab9e267c0bc76ff0017e07905c1f2f45dc440a9af89f6cae6aa
diff --git a/dev-python/httpx/httpx-0.22.0-r2.ebuild b/dev-python/httpx/httpx-0.23.0.ebuild
index 26e9b635b50c..f63c41c27f79 100644
--- a/dev-python/httpx/httpx-0.22.0-r2.ebuild
+++ b/dev-python/httpx/httpx-0.23.0.ebuild
@@ -8,13 +8,18 @@ EAPI=8
# DOCS_DEPEND="dev-python/mkdocs-material"
# DOCS_AUTODOC=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
inherit distutils-r1 optfeature # docs
DESCRIPTION="Fully-featured HTTP client which provides sync and async APIs"
-HOMEPAGE="https://www.python-httpx.org/"
+HOMEPAGE="
+ https://www.python-httpx.org/
+ https://github.com/encode/httpx/
+ https://pypi.org/project/httpx/
+"
SRC_URI="
- https://github.com/encode/${PN}/archive/${PV}.tar.gz
+ https://github.com/encode/httpx/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
"
@@ -25,11 +30,9 @@ IUSE="cli"
RDEPEND="
dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/charset_normalizer[${PYTHON_USEDEP}]
dev-python/sniffio[${PYTHON_USEDEP}]
- =dev-python/httpcore-0.14*[${PYTHON_USEDEP}]
+ =dev-python/httpcore-0.15*[${PYTHON_USEDEP}]
>=dev-python/rfc3986-1.3[${PYTHON_USEDEP}]
- <dev-python/rfc3986-2[${PYTHON_USEDEP}]
cli? (
=dev-python/click-8*[${PYTHON_USEDEP}]
=dev-python/pygments-2*[${PYTHON_USEDEP}]
@@ -54,7 +57,8 @@ BDEPEND="
distutils_enable_tests pytest
src_prepare() {
- sed -i -e '/rich/s:==10[.][*]:<13:' setup.py || die
+ # unpin deps
+ sed -i -e 's:==[0-9.*]\+::' -e 's:,<[0-9.]\+::' setup.py || die
if ! use cli; then
sed -i -e '/console_scripts/d' setup.py || die
fi
@@ -66,10 +70,6 @@ python_test() {
# Internet
tests/client/test_proxies.py::test_async_proxy_close
tests/client/test_proxies.py::test_sync_proxy_close
-
- # Result change in charset-normalizer-2.0.7+
- 'tests/test_decoders.py::test_text_decoder[data3-iso-8859-1]'
- 'tests/models/test_responses.py::test_response_no_charset_with_iso_8859_1_content'
)
local EPYTEST_IGNORE=()