summaryrefslogtreecommitdiff
path: root/dev-python/httpx-socks/httpx-socks-0.7.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-07 10:16:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-07 10:16:30 +0100
commit2c9fab2a3468abc6862cb3115c9ff63aa266bf57 (patch)
treeb9249df06dd8229d7f334cb2e536d5c56ac81d3c /dev-python/httpx-socks/httpx-socks-0.7.7.ebuild
parent0735b7c70f35339a20b45aee2a0a0ad80d118550 (diff)
gentoo auto-resync : 07:07:2023 - 10:16:30
Diffstat (limited to 'dev-python/httpx-socks/httpx-socks-0.7.7.ebuild')
-rw-r--r--dev-python/httpx-socks/httpx-socks-0.7.7.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/httpx-socks/httpx-socks-0.7.7.ebuild b/dev-python/httpx-socks/httpx-socks-0.7.7.ebuild
new file mode 100644
index 000000000000..dfe2e7e85e81
--- /dev/null
+++ b/dev-python/httpx-socks/httpx-socks-0.7.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Proxy (HTTP, SOCKS) transports for httpx"
+HOMEPAGE="
+ https://github.com/romis2012/httpx-socks/
+ https://pypi.org/project/httpx-socks/
+"
+# no tests in sdist, as of 0.7.6
+SRC_URI="
+ https://github.com/romis2012/httpx-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/httpx-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.21.0[${PYTHON_USEDEP}]
+ <dev-python/httpcore-0.18.0[${PYTHON_USEDEP}]
+ >=dev-python/httpcore-0.17.3[${PYTHON_USEDEP}]
+ >=dev-python/python-socks-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/hypercorn-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/starlette-0.19.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.18.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.6.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest