summaryrefslogtreecommitdiff
path: root/dev-python/httpstat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/httpstat
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/httpstat')
-rw-r--r--dev-python/httpstat/Manifest4
-rw-r--r--dev-python/httpstat/files/httpstat-1.2.1-gentoo-tests.patch30
-rw-r--r--dev-python/httpstat/httpstat-1.2.1.ebuild28
-rw-r--r--dev-python/httpstat/metadata.xml12
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/httpstat/Manifest b/dev-python/httpstat/Manifest
new file mode 100644
index 000000000000..37d6aafc0a37
--- /dev/null
+++ b/dev-python/httpstat/Manifest
@@ -0,0 +1,4 @@
+AUX httpstat-1.2.1-gentoo-tests.patch 838 BLAKE2B 6185274643fc1e67d5cb099f747bd595ddb38fb0ce2f335b3472952298dcb47dac63009d48fe328d22465e777e80b23af1668a6c1da1c62b5208648cb439e9d4 SHA512 a38e8984b9e06b47fb076f449ebc651646b68be448481ce9f197bf995a81c0b81c4ce3070508f597e4dd4bd9e7b5f17f8ae602c4d9978ff3e05b11f7ad7a048b
+DIST httpstat-1.2.1.tar.gz 97012 BLAKE2B 2c2ae97fe7c5f6563b3b29e8f40ec18ca62ab0efecd81bda404a57f594574d1647b9f72bea644a3e934670c0d142e4e1f9b866ed6cf215cd4183d6f574b252a5 SHA512 58636eacc7ad57fc6ab5fe477117547c515828e1dd50980d7c1d7c70d2fd04a8539339331bbf4e8a9ac9fea199626a45e7c3e2e458e11b78fb848027ff7c6a76
+EBUILD httpstat-1.2.1.ebuild 655 BLAKE2B 034a466a4b35156907acb386955eb2b0fad6d43ef1c11458cda0190b462ebe87fd043876f1112e565ab982a81c39024c6e955a41f41c71035565a28d44188fe6 SHA512 12f06a0abeff4a316740d301d5ef84c793c921d0469f4a832372139defbf091d16b76c32d19a58216abdd63e9a7d8ceb79e6e61efd3f44c416d01f1a2bfd4e18
+MISC metadata.xml 392 BLAKE2B 31931fd92505a57b10e74968337224c5bc19b3377e622ee8711ee56797e101797a4697f59a0ce38228472490072593b4b44042c8f904d432d502d88ad5297b19 SHA512 46e595a4b6ba41d5353316332d273c063103f39ca04659b56b95fe935603b5441ef5e317ece03de6469240091beb5e12e419fb7e7c57ebfcae7629f74004d7d7
diff --git a/dev-python/httpstat/files/httpstat-1.2.1-gentoo-tests.patch b/dev-python/httpstat/files/httpstat-1.2.1-gentoo-tests.patch
new file mode 100644
index 000000000000..2ce199a94b75
--- /dev/null
+++ b/dev-python/httpstat/files/httpstat-1.2.1-gentoo-tests.patch
@@ -0,0 +1,30 @@
+- Testscript doesn't need to run tests for multiple python implementations,
+ PM will take care of that.
+
+- Disabling test which requires specific locales.
+
+--- a/httpstat_test.sh
++++ b/httpstat_test.sh
+@@ -19,8 +19,7 @@ function title() {
+ http_url="google.com"
+ https_url="https://http2.akamai.com"
+
+-for pybin in python python3; do
+-#for pybin in python; do
++for pybin in python; do
+ echo
+ echo "# Test in $pybin"
+
+@@ -40,9 +39,9 @@ for pybin in python python3; do
+ main_silent $https_url
+ assert_exit 0
+
+- title "comma decimal language (ru_RU)"
+- LC_ALL=ru_RU main_silent $http_url
+- assert_exit 0
++ #title "comma decimal language (ru_RU)"
++ #LC_ALL=ru_RU main_silent $http_url
++ #assert_exit 0
+
+ title "HTTPSTAT_DEBUG"
+ HTTPSTAT_DEBUG=true main $http_url | grep -q 'HTTPSTAT_DEBUG=true'
diff --git a/dev-python/httpstat/httpstat-1.2.1.ebuild b/dev-python/httpstat/httpstat-1.2.1.ebuild
new file mode 100644
index 000000000000..2b9302f689b2
--- /dev/null
+++ b/dev-python/httpstat/httpstat-1.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="httpstat visualizes cURL statistics in a way of beauty and clarity"
+HOMEPAGE="https://github.com/reorx/httpstat"
+SRC_URI="https://github.com/reorx/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="net-misc/curl:*"
+
+# Requires access to google.com and http2.akamai.com
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.2.1-gentoo-tests.patch )
+
+python_test() {
+ ./httpstat_test.sh || die
+}
diff --git a/dev-python/httpstat/metadata.xml b/dev-python/httpstat/metadata.xml
new file mode 100644
index 000000000000..2dcc864feab4
--- /dev/null
+++ b/dev-python/httpstat/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>whissi@gentoo.org</email>
+ <name>Thomas Deutschmann</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/reorx/httpstat/issues</bugs-to>
+ <remote-id type="github">reorx/httpstat</remote-id>
+ </upstream>
+</pkgmetadata>