summaryrefslogtreecommitdiff
path: root/dev-python/httpcore
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 13:54:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 13:54:09 +0000
commit454de691f3543d47dc89cd0b137eaa9ea4640cd3 (patch)
tree90ec469ff7d2e1b1fac0b0f98f32d49dacb30278 /dev-python/httpcore
parente393c0503a79342594a61547dc43f80f8bcc086e (diff)
gentoo auto-resync : 21:12:2022 - 13:54:08
Diffstat (limited to 'dev-python/httpcore')
-rw-r--r--dev-python/httpcore/Manifest2
-rw-r--r--dev-python/httpcore/httpcore-0.16.3.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
index 0c418f6b04e7..17ee6824fc01 100644
--- a/dev-python/httpcore/Manifest
+++ b/dev-python/httpcore/Manifest
@@ -1,3 +1,5 @@
DIST httpcore-0.16.2.gh.tar.gz 78465 BLAKE2B f028bc524dcf865b5213d4ff21dcfff525ac34d4dfa1301ebc56392f3082b3b76b6ec1da5e50a01c416cd09d53ad5edd5f2a6d6d4f9dd78e8a579812c0cebc36 SHA512 d11fe4f6a59e2dc1bce6724941db5978f0863f73e39786121f775d9c1702a32741de2cb4a0588fc907294d1b244713222cc57ef19a0d66e4075075c621f17d9b
+DIST httpcore-0.16.3.gh.tar.gz 79132 BLAKE2B c06d55ce1390085db6c15d3e96160cfb037a935d1298304856defd1778783ad1954924a48653ce165dae9cde18abec157aa72865f57e97d91a564d1b823c863c SHA512 d889da0a3fee4f190ecc3981b8af34fa9b285d00f4ad92158a085c65f3ad8fa5a97a8c711bd51f8b9518b9d2c90ecd457dee1a3d7bbf853715473f4707cc421a
EBUILD httpcore-0.16.2.ebuild 1160 BLAKE2B ec17bbe6948f02b6b3bebbc1675bf36b6d7a990a5e5f8c5ec8664f6818be3f4e94e15567b8eb17cedb2f7a2817cda38cb1eece5435b287706495f94b5bf9511c SHA512 a4b5d9e3b9a90c55b7e7fedbd9da2b52153e57a331bb5913ed72e51b50b2e52c4384b8bfda3464dc0ffd8395bcced35c92d0a4b81f94d1f81b3d4c9512eaf91d
+EBUILD httpcore-0.16.3.ebuild 1168 BLAKE2B eb4f2e8bcb1c33d13d6cf8439572ce05f4d8094e6cbfbfa86283ef57be277aab8ea56dd01c6c3d0bb42b0fd6eb7d66a15a96e00bc4653e1aa338435028e70c14 SHA512 c188361f71fe5549105bd8db20e36d349b46f771c82080ad65b467a1af0b33ab85a5aadc41810307ba785ad5a9d6f6894277c7747c6c3aa6f69d689a3df1a3c6
MISC metadata.xml 454 BLAKE2B f8a48d9ab81e5f74623dd0c8490e5de5cc711fda7f4614932e7ac6caa80bd23436037ddf9327d6bddc3d39c8b601b4ee74a85c0a10bacb20514cbf8278e34d1f SHA512 af962141bd55f51b27e0d4b61bcf7d5426e816df4f8c65be257d8fddd597664afe04e78ebe7e11caaebf06ae4fe17b88f568dc440403865ba6b8e3b47d796aa6
diff --git a/dev-python/httpcore/httpcore-0.16.3.ebuild b/dev-python/httpcore/httpcore-0.16.3.ebuild
new file mode 100644
index 000000000000..621c94bfed43
--- /dev/null
+++ b/dev-python/httpcore/httpcore-0.16.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A minimal low-level HTTP client"
+HOMEPAGE="
+ https://www.encode.io/httpcore/
+ https://github.com/encode/httpcore/
+ https://pypi.org/project/httpcore/
+"
+SRC_URI="
+ https://github.com/encode/httpcore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ <dev-python/h11-0.15[${PYTHON_USEDEP}]
+ <dev-python/h2-5[${PYTHON_USEDEP}]
+ =dev-python/sniffio-1*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "SOCKS support" dev-python/socksio
+}