summaryrefslogtreecommitdiff
path: root/dev-python/httpcore/httpcore-0.17.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-06 23:58:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-06 23:58:42 +0100
commit992d51a146d493f8dd5d710e033427d323b9c739 (patch)
tree8463bd925b241d603b8a754ce50fd81e46ed7b86 /dev-python/httpcore/httpcore-0.17.3.ebuild
parent8368c614e6a1232f34a14cd6495cf2f68933030d (diff)
gentoo auto-resync : 06:10:2023 - 23:58:42
Diffstat (limited to 'dev-python/httpcore/httpcore-0.17.3.ebuild')
-rw-r--r--dev-python/httpcore/httpcore-0.17.3.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/httpcore/httpcore-0.17.3.ebuild b/dev-python/httpcore/httpcore-0.17.3.ebuild
deleted file mode 100644
index 3fa03d17a22a..000000000000
--- a/dev-python/httpcore/httpcore-0.17.3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="A minimal low-level HTTP client"
-HOMEPAGE="
- https://www.encode.io/httpcore/
- https://github.com/encode/httpcore/
- https://pypi.org/project/httpcore/
-"
-SRC_URI="
- https://github.com/encode/httpcore/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- <dev-python/anyio-5[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
- <dev-python/h11-0.15[${PYTHON_USEDEP}]
- <dev-python/h2-5[${PYTHON_USEDEP}]
- =dev-python/sniffio-1*[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/pytest-trio[${PYTHON_USEDEP}]
- dev-python/socksio[${PYTHON_USEDEP}]
- dev-python/trio[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-pkg_postinst() {
- optfeature "SOCKS support" dev-python/socksio
-}