summaryrefslogtreecommitdiff
path: root/dev-python/httpcore/httpcore-0.17.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-24 09:01:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-24 09:01:51 +0100
commitbd2c7873be3178619accade4259ba907b6baca46 (patch)
treea2dd247d39fd3cd02086ae2248b0cd590397320c /dev-python/httpcore/httpcore-0.17.2.ebuild
parenta5d03e5440b3955446fba6d02de9f53ea4f6efc4 (diff)
gentoo auto-resync : 24:05:2023 - 09:01:50
Diffstat (limited to 'dev-python/httpcore/httpcore-0.17.2.ebuild')
-rw-r--r--dev-python/httpcore/httpcore-0.17.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/httpcore/httpcore-0.17.2.ebuild b/dev-python/httpcore/httpcore-0.17.2.ebuild
new file mode 100644
index 000000000000..29b9667eb195
--- /dev/null
+++ b/dev-python/httpcore/httpcore-0.17.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A minimal low-level HTTP client"
+HOMEPAGE="
+ https://www.encode.io/httpcore/
+ https://github.com/encode/httpcore/
+ https://pypi.org/project/httpcore/
+"
+SRC_URI="
+ https://github.com/encode/httpcore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ <dev-python/h11-0.15[${PYTHON_USEDEP}]
+ <dev-python/h2-5[${PYTHON_USEDEP}]
+ =dev-python/sniffio-1*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "SOCKS support" dev-python/socksio
+}