summaryrefslogtreecommitdiff
path: root/dev-python/httpcore/httpcore-0.15.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-10 15:20:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-10 15:20:44 +0000
commit177349fb1459039cc30cb8e3936af4117d038c16 (patch)
tree34c1bc161daefb8e152212dfba02b98da8a777a5 /dev-python/httpcore/httpcore-0.15.0.ebuild
parentc15acf374d4b25ba5afcb52435da6090f2d98a20 (diff)
gentoo auto-resync : 10:12:2022 - 15:20:44
Diffstat (limited to 'dev-python/httpcore/httpcore-0.15.0.ebuild')
-rw-r--r--dev-python/httpcore/httpcore-0.15.0.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/httpcore/httpcore-0.15.0.ebuild b/dev-python/httpcore/httpcore-0.15.0.ebuild
deleted file mode 100644
index 59a6824e51c5..000000000000
--- a/dev-python/httpcore/httpcore-0.15.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="A minimal low-level HTTP client"
-HOMEPAGE="
- https://www.encode.io/httpcore/
- https://github.com/encode/httpcore/
- https://pypi.org/project/httpcore/
-"
-SRC_URI="
- https://github.com/encode/httpcore/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- =dev-python/anyio-3*[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
- <dev-python/h11-0.14[${PYTHON_USEDEP}]
- <dev-python/h2-5[${PYTHON_USEDEP}]
- =dev-python/sniffio-1*[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/pytest-trio[${PYTHON_USEDEP}]
- dev-python/socksio[${PYTHON_USEDEP}]
- dev-python/trio[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/h11/s:,<0.13::' setup.py || die
- distutils-r1_src_prepare
-}
-
-pkg_postinst() {
- optfeature "SOCKS support" dev-python/socksio
-}