summaryrefslogtreecommitdiff
path: root/dev-python/httpbin/httpbin-0.7.0-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/httpbin/httpbin-0.7.0-r4.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/httpbin/httpbin-0.7.0-r4.ebuild')
-rw-r--r--dev-python/httpbin/httpbin-0.7.0-r4.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/httpbin/httpbin-0.7.0-r4.ebuild b/dev-python/httpbin/httpbin-0.7.0-r4.ebuild
deleted file mode 100644
index 7750896348d1..000000000000
--- a/dev-python/httpbin/httpbin-0.7.0-r4.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP Request and Response Service"
-HOMEPAGE="
- https://github.com/postmanlabs/httpbin/
- https://pypi.org/project/httpbin/
-"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-RDEPEND="
- dev-python/brotlicffi[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- dev-python/markupsafe[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- <dev-python/werkzeug-2.1[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- # do not import raven if it's not going to be used
- # (upstream removed it completely in git anyway)
- "${FILESDIR}"/httpbin-0.7.0-optional-raven.patch
- # fix tests with new versions of werkzeug
- "${FILESDIR}"/httpbin-0.7.0-test-werkzeug.patch
- # use brotlicffi instead of brotlipy
- "${FILESDIR}"/httpbin-0.7.0-brotlicffi.patch
-)
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # a new version of flask or whatever converts relative redirects
- # to absolute; this package is dead anyway, so just skip
- # the relevant tests
- sed -e 's:test_redirect:_&:' \
- -e 's:test_relative:_&:' \
- -i test_httpbin.py || die
-
- distutils-r1_src_prepare
-}