summaryrefslogtreecommitdiff
path: root/dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch')
-rw-r--r--dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch b/dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch
index 8602ed7641be..5d626768bd27 100644
--- a/dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch
+++ b/dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch
@@ -17,3 +17,15 @@ diff -dupr a/httpbin/core.py b/httpbin/core.py
sentry = Sentry(app, dsn=os.environ['SENTRY_DSN'])
# Set up Bugsnag exception tracking, if desired. To use Bugsnag, install the
+diff --git a/setup.py b/setup.py
+index 7f9956b..3cab2ae 100644
+--- a/setup.py
++++ b/setup.py
+@@ -35,6 +35,6 @@ setup(
+ include_package_data = True, # include files listed in MANIFEST.in
+ install_requires=[
+ 'Flask', 'MarkupSafe', 'decorator', 'itsdangerous', 'six', 'brotlipy',
+- 'raven[flask]', 'werkzeug>=0.14.1'
++ 'werkzeug>=0.14.1'
+ ],
+ )