summaryrefslogtreecommitdiff
path: root/dev-python/httpauth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/httpauth
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/httpauth')
-rw-r--r--dev-python/httpauth/Manifest4
-rw-r--r--dev-python/httpauth/httpauth-0.3.ebuild26
-rw-r--r--dev-python/httpauth/metadata.xml17
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/httpauth/Manifest b/dev-python/httpauth/Manifest
new file mode 100644
index 000000000000..03a20ac829dd
--- /dev/null
+++ b/dev-python/httpauth/Manifest
@@ -0,0 +1,4 @@
+DIST httpauth-0.3.tar.gz 4440 SHA256 74645a5c3cf7d094fb3b6803b789453ade634f2eb7d177d149dfbf680e3a5a61 SHA512 aa35148322a1c5ffc22a132d3062d300118aa23181a0008018d0aacfd473758d86d50ff1236d88126858a53e2f45aeea938988b2d1a8f62f80a97d8c2cc69822 WHIRLPOOL 861600fd9912468d187bd982ffb2968756d5281be55e249fd0f175ecaf0d095965a24bbd3435f127fa629d609bfa1d999df772ae8d204199f0c478c3ff278b84
+EBUILD httpauth-0.3.ebuild 609 SHA256 1c50705585e18bd2f421b6befd2a607dbb9a6db75265f69dbb2dcc97e4103a6a SHA512 1fe43a4db2054a5bb944ed57259f3e0804ab2df091d08432fe7485c8e5c5a2a95b06f99e9b1ffa4413a16d1856ee154955d27d69b376db0f8ab5e5c4d56531c0 WHIRLPOOL 566c86d800992f62b0dd6988cc408c42337c31a4056a2b12569062963fb65cddc573442eea05c66203ac0d0dd39fa1dbf049d6b71020b319872e35cfeab2d344
+MISC ChangeLog 448 SHA256 ba96a98d54cfb9dd36f3068d8f5dba8780fc4d4ae26293d300994aa9de1b6ccf SHA512 f2dae240ee7f3091a1f983dd2e573a0d868280dc792b4fa53742a0550cbdb2b030523b261ba8d6d623f5e299ce56a685fff762bc03305fb9d07eae4603e9ad48 WHIRLPOOL 5a69878fb2df5049b5f1a3404d8b29c79f5140f73c2ae45138456aed1054b38a9ec837678a498206ae53b4e5e16c07088f651da3226573f1eadcf8cc6843b7e3
+MISC metadata.xml 564 SHA256 b4f7fbcfc3a2bc0192e7d1175d8736e7507fd5947b826118a02b251be106216c SHA512 0fc6fc882f8ef29b16e73e7e0e4559e2f30e2ac153370405c438e8f2e7267bfff7cb4a34e49e58ff0dce849596a4ca6a5dff2d5cbedf6508df2525504ecfab66 WHIRLPOOL 5c02b4188fa1443e5dbef05bc6298c7adf38e834bd563d0e1f8c8cb8d1e58c7798fc80bbc3feca78c2c606b75763c307add7f04c647ea087203b700bda4a1e41
diff --git a/dev-python/httpauth/httpauth-0.3.ebuild b/dev-python/httpauth/httpauth-0.3.ebuild
new file mode 100644
index 000000000000..49c87f86fbe0
--- /dev/null
+++ b/dev-python/httpauth/httpauth-0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI middleware that secures routes using HTTP Digest Authentication"
+HOMEPAGE="https://github.com/jonashaag/httpauth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ nosetests tests.py || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/httpauth/metadata.xml b/dev-python/httpauth/metadata.xml
new file mode 100644
index 000000000000..ce8b8302b0df
--- /dev/null
+++ b/dev-python/httpauth/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">httpauth</remote-id>
+ <remote-id type="github">jonashaag/httpauth</remote-id>
+ <bugs-to>https://github.com/jonashaag/httpauth/issues</bugs-to>
+ </upstream>
+</pkgmetadata>