summaryrefslogtreecommitdiff
path: root/dev-python/http-parser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/http-parser
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/http-parser')
-rw-r--r--dev-python/http-parser/Manifest3
-rw-r--r--dev-python/http-parser/http-parser-0.8.3.ebuild37
-rw-r--r--dev-python/http-parser/metadata.xml12
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/http-parser/Manifest b/dev-python/http-parser/Manifest
new file mode 100644
index 000000000000..c7bebcfc8fde
--- /dev/null
+++ b/dev-python/http-parser/Manifest
@@ -0,0 +1,3 @@
+DIST http-parser-0.8.3.tar.gz 83040 BLAKE2B 8ccfd15154e34756229159576340536e447a1b76375df7c3f56b96c79957a3b28569fd4a4e77303fd1d254aa5652478f7e319e7556150de563f5b12c58482de4 SHA512 aca583d976dcf172244179cc4199336f296dbb2e2838dded23e64d55f23298fe600f9c24ba6cb6d1d5faad3022710154949fd39adecaef763f7589a58d03fbd1
+EBUILD http-parser-0.8.3.ebuild 913 BLAKE2B 57c1c9ab68e6a908b33f34f09fc356098e5c691db8e4a39ef171b5560db845245867467bcba3afe0d59e140a1ee476991e1fc6767664d66922674560afe5f8c4 SHA512 d032b1e2d32fd074600230a4f5ec99729feaf204923bdb66e5fc227088a25aeb7a8f972884767e0c14bb324aa5bc897a8f7be52dcf47d675b963344241bfcf4a
+MISC metadata.xml 385 BLAKE2B 16371b248416d43a094b0038919816277b3dbced190f2684cbc6d0ff9cff6007cb7e5e44d867eff942f46173edf5018a4b15383454344fcfe003544aa3e64fba SHA512 5b4b7b992bf4036ee076a2714bd0b91540b071fac6194ade8327e71062d7dfc5597f68934c275d72756c5ebb25e334059df4112946a1a84ab20ca0710ee16760
diff --git a/dev-python/http-parser/http-parser-0.8.3.ebuild b/dev-python/http-parser/http-parser-0.8.3.ebuild
new file mode 100644
index 000000000000..11ee13c191f8
--- /dev/null
+++ b/dev-python/http-parser/http-parser-0.8.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="HTTP request/response parser for python in C"
+HOMEPAGE="https://github.com/benoitc/http-parser"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~ia64 ppc ppc64 ~s390 ~sparc x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' 'python*')"
+
+python_compile() {
+ if [[ ${EPYTHON} != python3* ]]; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_install_all() {
+ local DOCS=( README.rst )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/http-parser/metadata.xml b/dev-python/http-parser/metadata.xml
new file mode 100644
index 000000000000..ec7464a19b16
--- /dev/null
+++ b/dev-python/http-parser/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">http-parser</remote-id>
+ <remote-id type="github">benoitc/http-parser</remote-id>
+ </upstream>
+</pkgmetadata>