summaryrefslogtreecommitdiff
path: root/dev-python/html5lib/html5lib-1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /dev-python/html5lib/html5lib-1.1.ebuild
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'dev-python/html5lib/html5lib-1.1.ebuild')
-rw-r--r--dev-python/html5lib/html5lib-1.1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/html5lib/html5lib-1.1.ebuild b/dev-python/html5lib/html5lib-1.1.ebuild
index 3dc621cb73c5..3fddc1546717 100644
--- a/dev-python/html5lib/html5lib-1.1.ebuild
+++ b/dev-python/html5lib/html5lib-1.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
PYTHON_REQ_USE="xml(+)"
inherit distutils-r1
@@ -15,14 +15,15 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="test"
-RESTRICT+=" !test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pytest6.patch
+)
RDEPEND=">=dev-python/six-1.9[${PYTHON_USEDEP}]
dev-python/webencodings[${PYTHON_USEDEP}]"
BDEPEND="
test? (
- ${RDEPEND}
dev-python/pytest-expect[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
)"