summaryrefslogtreecommitdiff
path: root/dev-python/html5lib/html5lib-0.999999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/html5lib/html5lib-0.999999999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/html5lib/html5lib-0.999999999.ebuild')
-rw-r--r--dev-python/html5lib/html5lib-0.999999999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/html5lib/html5lib-0.999999999.ebuild b/dev-python/html5lib/html5lib-0.999999999.ebuild
new file mode 100644
index 000000000000..7e238cc4804a
--- /dev/null
+++ b/dev-python/html5lib/html5lib-0.999999999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="https://github.com/html5lib/html5lib-python/ https://html5lib.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-expect[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}