summaryrefslogtreecommitdiff
path: root/dev-python/hpack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-python/hpack
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-python/hpack')
-rw-r--r--dev-python/hpack/Manifest2
-rw-r--r--dev-python/hpack/hpack-3.0.0.ebuild30
2 files changed, 15 insertions, 17 deletions
diff --git a/dev-python/hpack/Manifest b/dev-python/hpack/Manifest
index ec9088195b8c..3309a0e55593 100644
--- a/dev-python/hpack/Manifest
+++ b/dev-python/hpack/Manifest
@@ -1,6 +1,6 @@
AUX hpack-3.0.0-hypothesis-healthcheck.patch 549 BLAKE2B 6177deb0b6a4de5fe5f2c65a82f8cd7eb7ef6140224070c0680b6c4646c111a063ec6a8c7d51ed2e56455eede1696abf6fb82f9d6d14d5aa81d58619b0c802bd SHA512 a1510a688d000b8f45ac48c39ba46336859f952356cf776d5204b512496c523e5dc622d16b17b50d0d6318bd94b817d52683e5f56287f0053ced2508cbf23259
DIST hpack-3.0.0.tar.gz 5305971 BLAKE2B d1df8a1b2a1ce8b91e63cab475d3957f937fb74c0bec343d342971be1bb7cfbc929c53cf041845df2965cef0cfb098345bf0612acabc7ef3e5e23f6f0aa44f2f SHA512 7b9cf5e643dff2a6454bfe419b797c8ed1a0fe6ec3b725d2696da5a820ab96fe87a64e600b1831c7024bd82616b155a0aa058301acb32172155b6538ba0a73c6
DIST hpack-4.0.0.tar.gz 5301419 BLAKE2B 0164f6aafc0d1f17f6c397efe710503a22501faae3c7dbba4e57ca2dc76e4d373bc5e65bf55acda8bc61975d12f8a2084de0e0c4587539e5a3102e3cf66d562b SHA512 f482d086d7a82649393e3cfea55c98966ce57055cb1826bc4dec1ea334661c02708e7903f2e8e588ee1c30df41373e1de9fb960c2e7bbc18d0ace0b8f97b195b
-EBUILD hpack-3.0.0.ebuild 1140 BLAKE2B f6a2fd48e83c6c7e922ab14023e3c3feda6df0147a78f597d5eeefdc354aced381422bf3860556c9fc970ae17078a8c5f210e9052eb0192c4993811b675bb616 SHA512 c265f09028d52bf7ec3e09db35dae7ad6c2ba0c0033fb9c02929eb12454fd04a842f2107da8de9daa8ceab4ede70dd361fd4d642c6c6eb5e2d5f1dddf2e6dc34
+EBUILD hpack-3.0.0.ebuild 974 BLAKE2B 607bc8aa01ab96927cc9ffee269e98d271d724d74fc55891952071cf39085005a0201f31e92e79afac2528d060e071699dce41dc01277ea95d1822128f07d8af SHA512 f01ce50154d99f293b8ba8f382695bacf22729a9499635fe8882c6c32da7ceba3004f3c7f7e90f972b24981bea64df091295b9b00754c95bd2735d799b5a0652
EBUILD hpack-4.0.0.ebuild 704 BLAKE2B 7ef22aa114dc804e8d0059d5f2ff295a891f923dfc0e3ca451683120ea655bfa26e1760cebee20d2b1d64d06b4e4e516fe7003f274a3fb229f701d493d81d0b9 SHA512 811c55c9a73322154d0d4ca688e3bd7280b5af23cb255c295ab5219871af8b5be027cf289d238eb9040f4bce1ab4fe9216e7203745a278bf8b08b4ee42183852
MISC metadata.xml 701 BLAKE2B ddbb1fb2ed0eff9436e212933ba3a6d91a3b439c3457bc613d00c0f8ec06468df44d4476f19a3bef9daa163938804ab2ef9ced38b51ef29a81f208a704599c4c SHA512 f464fca486d271112fe08d65f800858427269292720804ff620127bb5ff3aa920e334bb1155f1788feeeb98d02d0e60114d2801d97febd77031bd524758c4184
diff --git a/dev-python/hpack/hpack-3.0.0.ebuild b/dev-python/hpack/hpack-3.0.0.ebuild
index b52fcbda7054..99cf18dfe91d 100644
--- a/dev-python/hpack/hpack-3.0.0.ebuild
+++ b/dev-python/hpack/hpack-3.0.0.ebuild
@@ -1,42 +1,40 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_{7,8,9})
+EAPI=7
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
DESCRIPTION="Pure-Python HPACK header compression"
-HOMEPAGE="https://python-hyper.org/hpack/en/latest/ https://pypi.org/project/hpack/"
+HOMEPAGE="
+ https://python-hyper.org/hpack/en/latest/
+ https://pypi.org/project/hpack/"
SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND=""
# dev-python/pytest-relaxed causes tests to fail
-DEPEND="${RDEPEND}
+BDEPEND="
test? (
- >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
>=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
!!dev-python/pytest-relaxed[${PYTHON_USEDEP}]
)
"
+distutils_enable_tests pytest
+
PATCHES=(
"${FILESDIR}"/hpack-3.0.0-hypothesis-healthcheck.patch
)
-python_prepare_all() {
- # Remove a test that is not part of the mainstream tests
- # Also, it's data directory is not included in the release
- rm test/test_hpack_integration.py || die
- distutils-r1_python_prepare_all
-}
-
python_test() {
- pytest -vv hpack test || die "Tests fail with ${EPYTHON}"
+ local deselect=(
+ # relies on outdated exception strings
+ test/test_table.py::TestHeaderTable::test_get_by_index_out_of_range
+ )
+
+ epytest hpack test ${deselect[@]/#/--deselect }
}