summaryrefslogtreecommitdiff
path: root/dev-python/hpack/hpack-4.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /dev-python/hpack/hpack-4.0.0.ebuild
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'dev-python/hpack/hpack-4.0.0.ebuild')
-rw-r--r--dev-python/hpack/hpack-4.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/hpack/hpack-4.0.0.ebuild b/dev-python/hpack/hpack-4.0.0.ebuild
new file mode 100644
index 000000000000..3d2885a39310
--- /dev/null
+++ b/dev-python/hpack/hpack-4.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python HPACK header compression"
+HOMEPAGE="
+ https://python-hyper.org/hpack/en/latest/
+ https://pypi.org/project/hpack/"
+SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+# dev-python/pytest-relaxed causes tests to fail
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
+ !!dev-python/pytest-relaxed[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest