summaryrefslogtreecommitdiff
path: root/dev-python/hpack/hpack-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/hpack/hpack-3.0.0.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/hpack/hpack-3.0.0.ebuild')
-rw-r--r--dev-python/hpack/hpack-3.0.0.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/hpack/hpack-3.0.0.ebuild b/dev-python/hpack/hpack-3.0.0.ebuild
index 93a872a12ec6..8182bbb647f3 100644
--- a/dev-python/hpack/hpack-3.0.0.ebuild
+++ b/dev-python/hpack/hpack-3.0.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy)
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy)
inherit distutils-r1
@@ -12,8 +12,9 @@ SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND=""
# dev-python/pytest-relaxed causes tests to fail
@@ -25,6 +26,10 @@ DEPEND="${RDEPEND}
)
"
+PATCHES=(
+ "${FILESDIR}"/hpack-3.0.0-hypothesis-healthcheck.patch
+)
+
python_prepare_all() {
# Remove a test that is not part of the mainstream tests
# Also, it's data directory is not included in the release
@@ -33,5 +38,5 @@ python_prepare_all() {
}
python_test() {
- py.test -vv hpack test || die "Tests fail with ${EPYTHON}"
+ pytest -vv hpack test || die "Tests fail with ${EPYTHON}"
}