summaryrefslogtreecommitdiff
path: root/dev-python/hpack/hpack-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
commit520a5b56dff7c24c9d42eafec142cb78b44f8e3e (patch)
treef562f705600dbd2292e97c0b4145787c2a8d1f97 /dev-python/hpack/hpack-3.0.0.ebuild
parent3811bc3072bf19e2be351d2c63f81532945c0f21 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'dev-python/hpack/hpack-3.0.0.ebuild')
-rw-r--r--dev-python/hpack/hpack-3.0.0.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/dev-python/hpack/hpack-3.0.0.ebuild b/dev-python/hpack/hpack-3.0.0.ebuild
index 07eac8c2bbc1..ee4d15d69a51 100644
--- a/dev-python/hpack/hpack-3.0.0.ebuild
+++ b/dev-python/hpack/hpack-3.0.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy)
inherit distutils-r1
@@ -20,8 +20,6 @@ RDEPEND=""
DEPEND="${RDEPEND}
test? (
>=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-cov-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-1.14.0[${PYTHON_USEDEP}]
>=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
!!dev-python/pytest-relaxed[${PYTHON_USEDEP}]
)
@@ -35,7 +33,5 @@ python_prepare_all() {
}
python_test() {
- PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
- py.test -v hpack test/|| die
- cd test
+ py.test -vv hpack test || die "Tests fail with ${EPYTHON}"
}