summaryrefslogtreecommitdiff
path: root/dev-python/hiredis/hiredis-2.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-15 16:40:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-15 16:40:41 +0100
commit35d4e80ab08982deb97a95d1b47156c67b268492 (patch)
tree52930de679b53a2d0e6881a4b18305fa1b9c5466 /dev-python/hiredis/hiredis-2.3.0.ebuild
parent9b6120d8af003bb775da6737dfe42f8f580f59f6 (diff)
gentoo auto-resync : 15:07:2023 - 16:40:40
Diffstat (limited to 'dev-python/hiredis/hiredis-2.3.0.ebuild')
-rw-r--r--dev-python/hiredis/hiredis-2.3.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/hiredis/hiredis-2.3.0.ebuild b/dev-python/hiredis/hiredis-2.3.0.ebuild
new file mode 100644
index 000000000000..f84862162b67
--- /dev/null
+++ b/dev-python/hiredis/hiredis-2.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+MY_P=hiredis-py-${PV}
+DESCRIPTION="Python extension that wraps hiredis"
+HOMEPAGE="
+ https://github.com/redis/hiredis-py/
+ https://pypi.org/project/hiredis/
+"
+SRC_URI="
+ https://github.com/redis/hiredis-py/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="
+ >=dev-libs/hiredis-1.0.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/hiredis-2.2.2-system-libs.patch
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ rm -rf hiredis || die
+ epytest
+}