summaryrefslogtreecommitdiff
path: root/dev-python/hiredis/hiredis-2.2.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
commit1c33e521c460dc40899ce7bc919602b842ce27e2 (patch)
tree580eefad4cce1e883e7504b93352a9029b53036d /dev-python/hiredis/hiredis-2.2.2-r1.ebuild
parent65e4244e411c4f65f55f2aa91f39e228f4c0680b (diff)
gentoo auto-resync : 05:03:2023 - 23:52:45
Diffstat (limited to 'dev-python/hiredis/hiredis-2.2.2-r1.ebuild')
-rw-r--r--dev-python/hiredis/hiredis-2.2.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/hiredis/hiredis-2.2.2-r1.ebuild b/dev-python/hiredis/hiredis-2.2.2-r1.ebuild
new file mode 100644
index 000000000000..504ba13a0426
--- /dev/null
+++ b/dev-python/hiredis/hiredis-2.2.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python extension that wraps hiredis"
+HOMEPAGE="https://github.com/redis/hiredis-py/"
+SRC_URI="https://github.com/redis/hiredis-py/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/hiredis-1.0.0:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}-py-${PV}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-system-libs.patch
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd tests
+ epytest --import-mode=append
+}