summaryrefslogtreecommitdiff
path: root/dev-python/hiredis/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-05 11:25:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-05 11:25:00 +0100
commitad77dc19e91d2c023f80e11e8974536d80e3a743 (patch)
tree42bb312ab0eb61fd94103e3eddb65b134f6be5a4 /dev-python/hiredis/files
parent6de28447d66e6c47ee682740b840cdb67244d4b1 (diff)
gentoo auto-resync : 05:04:2023 - 11:25:00
Diffstat (limited to 'dev-python/hiredis/files')
-rw-r--r--dev-python/hiredis/files/hiredis-2.0.0-CVE-2021-32765.patch36
-rw-r--r--dev-python/hiredis/files/hiredis-2.0.0-system-libs.patch14
2 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/hiredis/files/hiredis-2.0.0-CVE-2021-32765.patch b/dev-python/hiredis/files/hiredis-2.0.0-CVE-2021-32765.patch
deleted file mode 100644
index ad1bb80ac0de..000000000000
--- a/dev-python/hiredis/files/hiredis-2.0.0-CVE-2021-32765.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/vendor/hiredis/alloc.c
-+++ b/vendor/hiredis/alloc.c
-@@ -68,6 +68,10 @@ void *hi_malloc(size_t size) {
- }
-
- void *hi_calloc(size_t nmemb, size_t size) {
-+ /* Overflow check as the user can specify any arbitrary allocator */
-+ if (SIZE_MAX / size < nmemb)
-+ return NULL;
-+
- return hiredisAllocFns.callocFn(nmemb, size);
- }
-
-diff --git a/alloc.h b/alloc.h
-index 34a05f4..771f9fe 100644
---- a/vendor/hiredis/alloc.h
-+++ b/vendor/hiredis/alloc.h
-@@ -32,6 +32,7 @@
- #define HIREDIS_ALLOC_H
-
- #include <stddef.h> /* for size_t */
-+#include <stdint.h>
-
- #ifdef __cplusplus
- extern "C" {
-@@ -59,6 +60,10 @@ static inline void *hi_malloc(size_t size) {
- }
-
- static inline void *hi_calloc(size_t nmemb, size_t size) {
-+ /* Overflow check as the user can specify any arbitrary allocator */
-+ if (SIZE_MAX / size < nmemb)
-+ return NULL;
-+
- return hiredisAllocFns.callocFn(nmemb, size);
- }
-
diff --git a/dev-python/hiredis/files/hiredis-2.0.0-system-libs.patch b/dev-python/hiredis/files/hiredis-2.0.0-system-libs.patch
deleted file mode 100644
index 74f14cdc00b4..000000000000
--- a/dev-python/hiredis/files/hiredis-2.0.0-system-libs.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- hiredis-2.0.0/setup.py
-+++ hiredis-2.0.0/setup.py
-@@ -11,9 +11,8 @@
- return module.__version__
-
- ext = Extension("hiredis.hiredis",
-- sources=sorted(glob.glob("src/*.c") +
-- ["vendor/hiredis/%s.c" % src for src in ("alloc", "read", "sds")]),
-- include_dirs=["vendor"])
-+ sources=sorted(glob.glob("src/*.c")),
-+ libraries=["hiredis"])
-
- setup(
- name="hiredis",