summaryrefslogtreecommitdiff
path: root/dev-python/helpdev/helpdev-0.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/helpdev/helpdev-0.7.1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/helpdev/helpdev-0.7.1.ebuild')
-rw-r--r--dev-python/helpdev/helpdev-0.7.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/helpdev/helpdev-0.7.1.ebuild b/dev-python/helpdev/helpdev-0.7.1.ebuild
new file mode 100644
index 000000000000..52bb4cf4873e
--- /dev/null
+++ b/dev-python/helpdev/helpdev-0.7.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Helping users and developers to get information about the environment"
+HOMEPAGE="https://gitlab.com/dpizetta/helpdev"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_{6,7,8} )
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? ( dev-python/pip[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest