summaryrefslogtreecommitdiff
path: root/dev-python/hcs-utils/hcs-utils-1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/hcs-utils/hcs-utils-1.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/hcs-utils/hcs-utils-1.5.ebuild')
-rw-r--r--dev-python/hcs-utils/hcs-utils-1.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/hcs-utils/hcs-utils-1.5.ebuild b/dev-python/hcs-utils/hcs-utils-1.5.ebuild
new file mode 100644
index 000000000000..98685b1f7b47
--- /dev/null
+++ b/dev-python/hcs-utils/hcs-utils-1.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P=${P/_rc/rc}
+DESCRIPTION="A library containing some useful snippets"
+HOMEPAGE="https://pypi.python.org/pypi/hcs_utils"
+SRC_URI="mirror://pypi/h/${PN/-/_}/${MY_P/-/_}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P/-/_}"
+
+python_test() {
+ pushd "${BUILD_DIR}/lib" > /dev/null
+ py.test --doctest-modules hcs_utils || die "Tests failed"
+}