summaryrefslogtreecommitdiff
path: root/dev-python/hcloud
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-18 17:04:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-18 17:04:41 +0000
commit6cdde4bf2702fac82ba7163fe9f922e7fa0b9a66 (patch)
tree876fe918d1abfd24cf9323208d2929b94a47cfc7 /dev-python/hcloud
parentce89e807ecd2194613ad6e6bcee8cf95e982ad1a (diff)
gentoo auto-resync : 18:11:2023 - 17:04:41
Diffstat (limited to 'dev-python/hcloud')
-rw-r--r--dev-python/hcloud/Manifest2
-rw-r--r--dev-python/hcloud/hcloud-1.32.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/hcloud/Manifest b/dev-python/hcloud/Manifest
index 858f06c15fc2..b07706cbcc2a 100644
--- a/dev-python/hcloud/Manifest
+++ b/dev-python/hcloud/Manifest
@@ -1,5 +1,7 @@
DIST hcloud-python-1.30.0.gh.tar.gz 108965 BLAKE2B b078310dcab67b37744ab285fe3c3207956f778de9c85fb64cbf4777250b3852a7bb19a6e2498a19bc1027a7b5edebc3aa0011192edf057ce1a1591e610387ef SHA512 459fdeff833a86c9c6869e06eac5b96250d2f0c9d1ebf55053c278ae8417af04611d4bb7bd89a757f75e5bc7303e13e235ba57496efcc59f63c38cf48fb87d82
DIST hcloud-python-1.31.0.gh.tar.gz 109239 BLAKE2B 26a58fe75386f98403afd6f13c55768fa676d130243c9c8ef70c0c6310e2ec76235eadc50122b2ce203f190244e0d36f4d7b05e07c2e8fbe5707120634e1ef6c SHA512 be3d3e643e970390faae6d3da9e75b754d167398a7a6d04f06a4dea1bc79c160a39184365019ed1f8c7242a85f5deb9d43d8923cc1907861d38089fe8835ed62
+DIST hcloud-python-1.32.0.gh.tar.gz 109858 BLAKE2B 7e242a92c81278facd7f9d2042d2d36787153215a72e97da7616f7d6b6ca6c06fadfd6b33bdab3699a8d8ac6ec1d7327b78a224a3f674a13a7d06791e91d4658 SHA512 013cd3a7e54b12348e4ec87e489b461c41822a85cd9fafc4421a8bb404ecf1fa079d99217db5f770e893ab9bb7223b588e4429968b8339b4d23654610dfa80c3
EBUILD hcloud-1.30.0.ebuild 1131 BLAKE2B 635b12b80f9609d9c911a2d5bad3b082f1496d9e1cca1b2fd7429913f1d67508b4fa7532653433121aec6e315faca5b6b3e14ed48fe18c2ecd096c5ae4dcd708 SHA512 deb6df221c879f66c16ce9882f01b47bb67dd73bd24d15569580d7c6c16bd7e369692cb13125fcd38cfba403e7dd1de9bcaee5a5794db188d7e427f3bbde03f7
EBUILD hcloud-1.31.0.ebuild 1132 BLAKE2B 36c8da11a3c3e0a252a19fc9f62ac9baa408e6cfd28948cec5b0a490898702cb2885c5376b47a319c3ed9969ef38d9817449841ebcd50f5440865404627b3af1 SHA512 0181d301d65203d7fd0679a5a4973b5e264402b799f645c1dcafb6354fdea734e60858716c97690eb077ed222aa05532166d06b7f1273fd0a22b647583d9624a
+EBUILD hcloud-1.32.0.ebuild 1132 BLAKE2B 36c8da11a3c3e0a252a19fc9f62ac9baa408e6cfd28948cec5b0a490898702cb2885c5376b47a319c3ed9969ef38d9817449841ebcd50f5440865404627b3af1 SHA512 0181d301d65203d7fd0679a5a4973b5e264402b799f645c1dcafb6354fdea734e60858716c97690eb077ed222aa05532166d06b7f1273fd0a22b647583d9624a
MISC metadata.xml 483 BLAKE2B c945a22b776b5bf73deabf93718a1dea3a9b98f7257467e845106f71910347a803f96ef969227d7c10a119f1e35b904bcb7501b9672bf3ce5a2bef112d903e56 SHA512 4a6540a06d57eb3bc8c455d982531427157fbf1a85abf4b909032b0880c9e2847b295b3c9b02378be35e88f74876357503dd04bbe544ff9a9612df2b1c321b1c
diff --git a/dev-python/hcloud/hcloud-1.32.0.ebuild b/dev-python/hcloud/hcloud-1.32.0.ebuild
new file mode 100644
index 000000000000..498400383d05
--- /dev/null
+++ b/dev-python/hcloud/hcloud-1.32.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=hcloud-python-${PV}
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="
+ https://github.com/hetznercloud/hcloud-python/
+ https://pypi.org/project/hcloud/
+"
+# sdist is missing doc assets as of 1.19.0
+# https://github.com/hetznercloud/hcloud-python/pull/183
+SRC_URI="
+ https://github.com/hetznercloud/hcloud-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ tests/integration
+)
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}