summaryrefslogtreecommitdiff
path: root/dev-python/hcloud
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-04 08:06:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-04 08:06:08 +0100
commit2a8d2f71d1d9963368e0ef3d641d75979a689d12 (patch)
tree83e283f960ab2ebbc1a042b8ed6c37b78d47b37b /dev-python/hcloud
parent8435c842b9e8fbb2bcc80397ab3aa655000459e2 (diff)
gentoo auto-resync : 04:07:2024 - 08:06:07
Diffstat (limited to 'dev-python/hcloud')
-rw-r--r--dev-python/hcloud/Manifest2
-rw-r--r--dev-python/hcloud/hcloud-2.0.1.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/hcloud/Manifest b/dev-python/hcloud/Manifest
index 6813c2d632e8..bf420cd1d9be 100644
--- a/dev-python/hcloud/Manifest
+++ b/dev-python/hcloud/Manifest
@@ -1,3 +1,5 @@
DIST hcloud-python-1.35.0.gh.tar.gz 114672 BLAKE2B 1742d571fccc369245d9bf9c8f85da1c37061a13368dfe928b666e4f514ed5bf9f87f61bc4e5859ec7a759f5dfa6364c60ff851572071b46b2df21c0fe6f02a6 SHA512 48cee279b4f0025c61662304e67b8cee6a718c071f801daac440054439dedb21ab656c244f486860b056edd8bdc9330d3134ec936085297f24442a93cbbcc9e4
+DIST hcloud-python-2.0.1.gh.tar.gz 117015 BLAKE2B e795ea4a114c8e2c71554f84646b574e94030c6e724456786a437cc58d3dd96118c274111bc3787d8e7074b81f0c2493b3c6c5b824f6a8acb6d3a70b4dd75d29 SHA512 2507687324579240d2ff89287a6bd8e90dd33bb1290514c925e7e786330032187fdf133af196a6c0529ecb7018003356e299fc00cbf5bf2819d1f8e229702a04
EBUILD hcloud-1.35.0.ebuild 1131 BLAKE2B d48357b1df12bfc680b99f284e36cbff05ea7eda1da03ece87716892216d713586faf4c6666805adcd5f9064f939ec8eb9f62823e3dcf1208ccd935e535205b0 SHA512 54a16490b36d75bc840f7e567c7479af0a6237224626cd2d168053469e3242066690b5d6a4197440d09646a7b3602a75f2e1addce9c202a85b9e3b5f0a8dd439
+EBUILD hcloud-2.0.1.ebuild 1132 BLAKE2B 9d958a4f4753e27be5b55a91cfbe4c0e54b058ac1add4b72b9b33cd1c73b8cd679b7b798508a6e029a6cf1519353b78108b9fcc0f450c2e15d2540e8a80e9284 SHA512 d83a35004bcdcaed9c1a96c6bad6a692e4ac52fd3b3b5392762fab068a482039c21361a818fa4eb0e97090f5497a70603476292e3dd4fdb1a5749961bedf1b39
MISC metadata.xml 483 BLAKE2B c945a22b776b5bf73deabf93718a1dea3a9b98f7257467e845106f71910347a803f96ef969227d7c10a119f1e35b904bcb7501b9672bf3ce5a2bef112d903e56 SHA512 4a6540a06d57eb3bc8c455d982531427157fbf1a85abf4b909032b0880c9e2847b295b3c9b02378be35e88f74876357503dd04bbe544ff9a9612df2b1c321b1c
diff --git a/dev-python/hcloud/hcloud-2.0.1.ebuild b/dev-python/hcloud/hcloud-2.0.1.ebuild
new file mode 100644
index 000000000000..64eceb0a363c
--- /dev/null
+++ b/dev-python/hcloud/hcloud-2.0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=hcloud-python-${PV}
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="
+ https://github.com/hetznercloud/hcloud-python/
+ https://pypi.org/project/hcloud/
+"
+# sdist is missing doc assets as of 1.19.0
+# https://github.com/hetznercloud/hcloud-python/pull/183
+SRC_URI="
+ https://github.com/hetznercloud/hcloud-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ tests/integration
+)
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}