summaryrefslogtreecommitdiff
path: root/dev-python/hcloud/hcloud-1.31.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 14:39:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 14:39:50 +0100
commitf63d9a9a54cdeeaadc78e460b82f2c9895a69384 (patch)
treec670cb8eb532d97c0d547a9845a6c8c8edbc4070 /dev-python/hcloud/hcloud-1.31.0.ebuild
parent386855c4d1ef509c1fd32abd721589c81669613b (diff)
gentoo auto-resync : 23:10:2023 - 14:39:50
Diffstat (limited to 'dev-python/hcloud/hcloud-1.31.0.ebuild')
-rw-r--r--dev-python/hcloud/hcloud-1.31.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/hcloud/hcloud-1.31.0.ebuild b/dev-python/hcloud/hcloud-1.31.0.ebuild
new file mode 100644
index 000000000000..498400383d05
--- /dev/null
+++ b/dev-python/hcloud/hcloud-1.31.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=hcloud-python-${PV}
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="
+ https://github.com/hetznercloud/hcloud-python/
+ https://pypi.org/project/hcloud/
+"
+# sdist is missing doc assets as of 1.19.0
+# https://github.com/hetznercloud/hcloud-python/pull/183
+SRC_URI="
+ https://github.com/hetznercloud/hcloud-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ tests/integration
+)
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}