summaryrefslogtreecommitdiff
path: root/dev-python/hcloud-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-20 13:16:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-20 13:16:21 +0100
commit332b9eb4903f99b0e65722058ce481fdc21b93d3 (patch)
treefef4ca14ec13f6bc1b3f532a6b2c19f7db4f3921 /dev-python/hcloud-python
parent7d1fc8f13082082c2539f20beadcf37089543b8e (diff)
gentoo auto-resync : 20:06:2023 - 13:16:21
Diffstat (limited to 'dev-python/hcloud-python')
-rw-r--r--dev-python/hcloud-python/Manifest2
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.21.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/hcloud-python/Manifest b/dev-python/hcloud-python/Manifest
index 5f3ceb63a26e..806e8ae73c12 100644
--- a/dev-python/hcloud-python/Manifest
+++ b/dev-python/hcloud-python/Manifest
@@ -1,3 +1,5 @@
DIST hcloud-python-1.20.0.gh.tar.gz 100107 BLAKE2B 584e1399ddb1c5d1e5ad0beaf795609bb63d37457afe33c663cf303f8b20e2c6f6b3ff294007e9f4ae2d9aa833794e59516ad167f1dd51d14e692f6eab887881 SHA512 b17abc716ae6f7c78803096f2fd887e47ee746fccbe299cc434b7f445abdd7818e445d186f5adacc715971e2ebe2e92551cdb08aa1891ed58d8f443ea3be61fb
+DIST hcloud-python-1.21.0.gh.tar.gz 102150 BLAKE2B 4ec6fb813f61f3c487d632e12a71f9105af5d45a307567fd2b22ff716e30c645bffebc5cd768846fc7d7892ab753d3e4487a1b72edfee62fb99dfefe188be41d SHA512 8226a79324f0097d576cc1336e813a28a562fb9c3f50dcac1debb3c32bb52f4f5e563e920e2bbb6ce8be407a65de321b734d30156fd066d74ed95f6e6bd94a35
EBUILD hcloud-python-1.20.0.ebuild 1046 BLAKE2B f2c7f38ee3a6f1e58d5486a0e6255191ff832b4165fafbe08e3af3fbff2a4b55a2d7268a8ad87bef5ed53ca731b8b5a4591adfdf694dfa97302ef3af0d1f53df SHA512 2e6db7fa1a08b69db9bc90a5f5e74bda2d7e1fb44343f0598b9ce137c763c95a13930fc97a8bba26f3193a8102d31fdc83b5f87992fe3ea7f1048854b93c4f7b
+EBUILD hcloud-python-1.21.0.ebuild 1098 BLAKE2B 9486b9380fa0a8e07aaeb22d45e195db384a1d1f62275617c4f264c1ede18f25300fa1e7b4a1b174245dadc919054e0b854c52cd0bf62f98ccfc1e7e4c3b339b SHA512 4019e4aef91954555fee9e24626a2e5d9b7772a010d7df418f50efc50d100a9aba35eb1c24d5d36c50eaa3fc67c83496d1966ed0ade88fa5fe9816edfb2ba85c
MISC metadata.xml 483 BLAKE2B c945a22b776b5bf73deabf93718a1dea3a9b98f7257467e845106f71910347a803f96ef969227d7c10a119f1e35b904bcb7501b9672bf3ce5a2bef112d903e56 SHA512 4a6540a06d57eb3bc8c455d982531427157fbf1a85abf4b909032b0880c9e2847b295b3c9b02378be35e88f74876357503dd04bbe544ff9a9612df2b1c321b1c
diff --git a/dev-python/hcloud-python/hcloud-python-1.21.0.ebuild b/dev-python/hcloud-python/hcloud-python-1.21.0.ebuild
new file mode 100644
index 000000000000..dd4634b4612d
--- /dev/null
+++ b/dev-python/hcloud-python/hcloud-python-1.21.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=hcloud-python-${PV}
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="
+ https://github.com/hetznercloud/hcloud-python/
+ https://pypi.org/project/hcloud/
+"
+# sdist is missing doc assets as of 1.19.0
+# https://github.com/hetznercloud/hcloud-python/pull/183
+SRC_URI="
+ https://github.com/hetznercloud/${PN}/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ tests/integration
+)
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}