summaryrefslogtreecommitdiff
path: root/dev-python/hcloud-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/hcloud-python
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/hcloud-python')
-rw-r--r--dev-python/hcloud-python/Manifest2
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.17.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/hcloud-python/Manifest b/dev-python/hcloud-python/Manifest
index 52553573154a..bb21834c1439 100644
--- a/dev-python/hcloud-python/Manifest
+++ b/dev-python/hcloud-python/Manifest
@@ -1,3 +1,5 @@
DIST hcloud-python-1.16.0.tar.gz 93731 BLAKE2B d94881550dbd08281226b9869008ea6c4a10bc544a21a5aa17e48d4862808baa92b4805dc101ea970bf66baca1f5a971912601c4b934fe47614351029ece9f04 SHA512 282d1accb3c387caefe9dce7ab70dccfe2ff830c6ec3cd665326ad79076d7f9e58ab2f3061fa262208731c9d1e09e6c52d13075adf119f8b19d6af50e0374556
+DIST hcloud-python-1.17.0.gh.tar.gz 98069 BLAKE2B b8fb2f1c4a3d139225a19599f956a845789872642bc62ec0434f5393e90f5ef64226b6363eeae0b3312084312aac4ddbe77e6e134b0502783e72568f23a71ee5 SHA512 829972585b5fe61aaaa2ee5294c97e6ad4a913229e8d87cec8e00d61480a780682b4eb75e2b9da5962bdb3dfda15b0a81afa74383be874e381a5f8e1a27d7014
EBUILD hcloud-python-1.16.0.ebuild 992 BLAKE2B 3dd0917dec46e69ef727bc7624377ee988f2e0c81e55686441c9acb379089c68c4f24c8d672688fcc4f01cf081784e6f9062f3e468e7a867d0df2e06be0fe38b SHA512 1d84e62018caae9fc8f55e1f4af7c4eedc5061d3dd718e64189c5507036621909429e0cd5b08ef11866f3b647b2effd37ac7b887ab80e83822faa3d2ccbcaf7f
+EBUILD hcloud-python-1.17.0.ebuild 1003 BLAKE2B 80a8500a3bd1be5daef964218c6a45d33e5072938409e8556c05e5c9282a962dd3015004bd26c722a15edc65fc036f305fcea7b7662154b16e8ac9ba04040b6d SHA512 23d3ef108deeb2ff8c284d9f69c38ed981996b20c2fcd52d6f1b53f0efdb37f08a586ebb9932a302dfda762cfb994a59324e2dc24d43c4e3a614f33f6304fed3
MISC metadata.xml 483 BLAKE2B c945a22b776b5bf73deabf93718a1dea3a9b98f7257467e845106f71910347a803f96ef969227d7c10a119f1e35b904bcb7501b9672bf3ce5a2bef112d903e56 SHA512 4a6540a06d57eb3bc8c455d982531427157fbf1a85abf4b909032b0880c9e2847b295b3c9b02378be35e88f74876357503dd04bbe544ff9a9612df2b1c321b1c
diff --git a/dev-python/hcloud-python/hcloud-python-1.17.0.ebuild b/dev-python/hcloud-python/hcloud-python-1.17.0.ebuild
new file mode 100644
index 000000000000..16f234d26482
--- /dev/null
+++ b/dev-python/hcloud-python/hcloud-python-1.17.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="https://github.com/hetznercloud/hcloud-python"
+SRC_URI="
+ https://github.com/hetznercloud/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-python/future-0.17.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ epytest --ignore tests/integration
+}