summaryrefslogtreecommitdiff
path: root/dev-python/hatchling
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-10 23:44:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-10 23:44:42 +0100
commitf356af92b88d56b78588e81310493d4f5a2f6d18 (patch)
tree0326fb33173ae3d096527af28f85685515533fbb /dev-python/hatchling
parent560358ad7081e6bb2a4e097d4c442b0bab626163 (diff)
gentoo auto-resync : 10:05:2023 - 23:44:41
Diffstat (limited to 'dev-python/hatchling')
-rw-r--r--dev-python/hatchling/Manifest2
-rw-r--r--dev-python/hatchling/hatchling-1.15.0.ebuild6
2 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/hatchling/Manifest b/dev-python/hatchling/Manifest
index 16291809d005..ee31bde747cc 100644
--- a/dev-python/hatchling/Manifest
+++ b/dev-python/hatchling/Manifest
@@ -5,5 +5,5 @@ DIST hatch-hatchling-v1.15.0.gh.tar.gz 382326 BLAKE2B 14095fc4355baef2bd7ba6156d
EBUILD hatchling-1.13.0.ebuild 2094 BLAKE2B 2e7a1d5a394a93f6d58a50b039fc9297393513803b0ae7bb551680a32321ed5940577acc02e6988865b0b026e0538f9b6efe24a9770e8c771ea5138e1de16aec SHA512 1cbe612df37be3a58213f1defd8df82469313a009cd77a9774e7ea16c615efe8fb0fd4127dc7e349daac0d9c1dd49fc3ff7629f14719f5d63dd4382c05514477
EBUILD hatchling-1.14.0.ebuild 2129 BLAKE2B ec0a8a969de23bf759f00de4eb8113e7a83c686fad2e900fee097bc59e386183315cc9404aee6ca505cb387057ec1358c1026c41957250c08425ac3df8f7ada7 SHA512 8d1ffe7b3b8ae177c09066d4d44a953bd41f2e38c4dd7921b483a9d70ce3790058f9b26a904aa63408135f38131f88ba3a1a5d6caa42a0f7d6ae4b64f31426fe
EBUILD hatchling-1.14.1.ebuild 2254 BLAKE2B 9344dd5d7191a73c1374655064f3e1705976f2ca668481b6d096f68457572d1dab30a30d8bdaeebeefb6fd359dfa0ddf657cfac9679c430704c4d430dafdf469 SHA512 9f0832cd980970ea08d58e9a80908307eff7c9dce61dd25ca92d7156bdc9b548fae8029415b253ada84b8d22a5a8a937b7648d4535878ecbf51e425fbf20a70e
-EBUILD hatchling-1.15.0.ebuild 2254 BLAKE2B 9344dd5d7191a73c1374655064f3e1705976f2ca668481b6d096f68457572d1dab30a30d8bdaeebeefb6fd359dfa0ddf657cfac9679c430704c4d430dafdf469 SHA512 9f0832cd980970ea08d58e9a80908307eff7c9dce61dd25ca92d7156bdc9b548fae8029415b253ada84b8d22a5a8a937b7648d4535878ecbf51e425fbf20a70e
+EBUILD hatchling-1.15.0.ebuild 2534 BLAKE2B 0af878a20ee9050d7e00b016e6faaf2bb7814465c43a69334aa7a9aac63a8c2c5838ea66da986a5bef108466b3d9456d02e5050c605c445455e926e191dedeb0 SHA512 2ce5980db8fa0fcce9cfd3b96822c327ec119520205f0511b568dae8e974f6f8a63d02e6d9619f10cc3c979128803c23d046369c1b82481482875d48160660c3
MISC metadata.xml 365 BLAKE2B 5a40a6cf6df042e6e8387830babd0171c9d8bc5d490fe2175b83d1588d827e826b49044ef29de48553515996b742fc475bb9699dcfa8ec05229162b22e0ed317 SHA512 f11bb25bc12c2bb0b0a0a4691115b9a2af525d9e44b33e0d6db98c7fcef0b49b5989fb7574ee8b27bc88f1dd2543bfdd492a6614de172e2c4edabbee8bf6161e
diff --git a/dev-python/hatchling/hatchling-1.15.0.ebuild b/dev-python/hatchling/hatchling-1.15.0.ebuild
index fb49ea0b336a..a71cd5b7faf4 100644
--- a/dev-python/hatchling/hatchling-1.15.0.ebuild
+++ b/dev-python/hatchling/hatchling-1.15.0.ebuild
@@ -45,6 +45,7 @@ BDEPEND="
dev-python/click[${PYTHON_USEDEP}]
dev-python/httpx[${PYTHON_USEDEP}]
dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/rich[${PYTHON_USEDEP}]
dev-python/tomli-w[${PYTHON_USEDEP}]
dev-python/virtualenv[${PYTHON_USEDEP}]
@@ -68,11 +69,16 @@ python_test() {
tests/backend/dep/test_core.py::test_extra_unmet
tests/backend/dep/test_core.py::test_unknown_extra
tests/backend/dep/test_core.py::test_version_unmet
+ # broken if CARGO is set
+ tests/backend/builders/test_app.py::TestBuildBootstrap::test_no_cargo
)
# top-level "tests" directory contains tests both for hatch
# and hatchling
cd "${WORKDIR}/${MY_P}" || die
local -x PYTHONPATH="src:${PYTHONPATH}"
+ # tests mock cargo subprocess call but the backend raises if CARGO
+ # is not set and shutil.which() can't find it
+ local -x CARGO=cargo
epytest tests/backend
}