summaryrefslogtreecommitdiff
path: root/dev-python/hatchling/hatchling-1.15.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-10 23:44:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-10 23:44:42 +0100
commitf356af92b88d56b78588e81310493d4f5a2f6d18 (patch)
tree0326fb33173ae3d096527af28f85685515533fbb /dev-python/hatchling/hatchling-1.15.0.ebuild
parent560358ad7081e6bb2a4e097d4c442b0bab626163 (diff)
gentoo auto-resync : 10:05:2023 - 23:44:41
Diffstat (limited to 'dev-python/hatchling/hatchling-1.15.0.ebuild')
-rw-r--r--dev-python/hatchling/hatchling-1.15.0.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/hatchling/hatchling-1.15.0.ebuild b/dev-python/hatchling/hatchling-1.15.0.ebuild
index fb49ea0b336a..a71cd5b7faf4 100644
--- a/dev-python/hatchling/hatchling-1.15.0.ebuild
+++ b/dev-python/hatchling/hatchling-1.15.0.ebuild
@@ -45,6 +45,7 @@ BDEPEND="
dev-python/click[${PYTHON_USEDEP}]
dev-python/httpx[${PYTHON_USEDEP}]
dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/rich[${PYTHON_USEDEP}]
dev-python/tomli-w[${PYTHON_USEDEP}]
dev-python/virtualenv[${PYTHON_USEDEP}]
@@ -68,11 +69,16 @@ python_test() {
tests/backend/dep/test_core.py::test_extra_unmet
tests/backend/dep/test_core.py::test_unknown_extra
tests/backend/dep/test_core.py::test_version_unmet
+ # broken if CARGO is set
+ tests/backend/builders/test_app.py::TestBuildBootstrap::test_no_cargo
)
# top-level "tests" directory contains tests both for hatch
# and hatchling
cd "${WORKDIR}/${MY_P}" || die
local -x PYTHONPATH="src:${PYTHONPATH}"
+ # tests mock cargo subprocess call but the backend raises if CARGO
+ # is not set and shutil.which() can't find it
+ local -x CARGO=cargo
epytest tests/backend
}