summaryrefslogtreecommitdiff
path: root/dev-python/happybase/happybase-1.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-03 23:26:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-03 23:26:49 +0100
commitfd7bf06d88ac431e7d531701551815fd63c73963 (patch)
tree6ec536a36d9e6a2e9096f2b385441c5c56f44922 /dev-python/happybase/happybase-1.2.0-r1.ebuild
parent3cf27339901a7ca15df33f6ea134daa93888d5d0 (diff)
gentoo auto-resync : 03:05:2023 - 23:26:49
Diffstat (limited to 'dev-python/happybase/happybase-1.2.0-r1.ebuild')
-rw-r--r--dev-python/happybase/happybase-1.2.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/happybase/happybase-1.2.0-r1.ebuild b/dev-python/happybase/happybase-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..3abcbdcf6c5e
--- /dev/null
+++ b/dev-python/happybase/happybase-1.2.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+COMMIT_HASH="f5b6d104140c2be93e4175c0c844aaf094eb43da"
+
+DESCRIPTION="A developer-friendly Python library to interact with Apache HBase"
+HOMEPAGE="
+ https://github.com/python-happybase/happybase
+ https://happybase.readthedocs.io/
+"
+SRC_URI="
+ https://github.com/python-happybase/happybase/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/thriftpy2[${PYTHON_USEDEP}]
+"
+
+# tests require a running thrift server
+RESTRICT="test"
+
+distutils_enable_tests pytest