summaryrefslogtreecommitdiff
path: root/dev-python/h2/h2-4.1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/h2/h2-4.1.0-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/h2/h2-4.1.0-r1.ebuild')
-rw-r--r--dev-python/h2/h2-4.1.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/h2/h2-4.1.0-r1.ebuild b/dev-python/h2/h2-4.1.0-r1.ebuild
new file mode 100644
index 000000000000..c234292ac410
--- /dev/null
+++ b/dev-python/h2/h2-4.1.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP/2 State-Machine based protocol implementation"
+HOMEPAGE="
+ https://python-hyper.org/projects/h2/en/stable/
+ https://github.com/python-hyper/h2/
+ https://pypi.org/project/h2/"
+SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ >=dev-python/hyperframe-6.0[${PYTHON_USEDEP}]
+ <dev-python/hyperframe-7[${PYTHON_USEDEP}]
+ >=dev-python/hpack-4.0[${PYTHON_USEDEP}]
+ <dev-python/hpack-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest